Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had Ubuntu 12.04 LTS and I recently upgraded to 12.10. Though I already have git 1.8 installed, update-manager keeps trying to install git and git-man version 1.7 (which obviously fails)!

Any idea why that happens? How can I get rid of that update?!

Screenshot:

share|improve this question
    
@Ramhound Thanks for attaching the image. –  Fardin Jul 18 '13 at 12:06
    
Use a different repository if you want a newer git version: How can I update to a newer version of Git –  Marco Jul 18 '13 at 14:56
    
@Marco I used checkinstall which, I believe, creates a .deb file; and as you can see in the screenshot, it is detected by apt. That's what I'm curious about! It's a clean installation, yet update-manager still offers an earlier version! –  Fardin Jul 18 '13 at 15:06
add comment

1 Answer

If you check on the ubuntu package list, for the 12.10 ubuntu version the git version is 1.7.10.4.

I don't know how you install the 1.8 version, but you're suppose to have the 1.7 version if you use the original ubuntu 12.10 repository list.

share|improve this answer
    
Well, I need to have 1.8! Can I, somehow, edit the list or sth.?! –  Fardin Jul 18 '13 at 13:55
    
You can't edit this list, it's the ubuntu official list. However, you can add this ppa and always has the latest git release. –  Just1602 Jul 18 '13 at 23:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.