Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Update : (19/07/13) If I yank the ethernet cable out (to put it back in again) to force my laptop to recognise the wired connection, my entire laptop freezes. Only hard reset -- power off and power on, is able to fix this. Closing the lid, Ctrl+Alt+Del.... nothing works! Somebody has any idea on this behaviour? End update

I am running Windows 7 Home Premium Sp1 64 bits on Toshiba Laptop (Atheros LAN and Broadcom wifi). I have a broadband connection at home and at any given time, my laptop connects to the Internet with the wifi.

Once it establishes the connection, I am unable to make the computer use the ethernet for connecting to Internet. I have to use the Fn+Fx keys to physically disable wifi before Windows even thinks of using the Wired connection. Usually this does not happen automatically either. I need to plug/unplug the cable several times, make the machine to sleep/wakeup, etc, sometimes in combination before Wired connection is activated.

Often, after Wired is finally setup, if I enable wifi, both connections show as "connected to Internet"!

Question is, is it possible to have both Wired and Wireless connectivity to the Net at the same time? If so how?

  • I don't have a CISCO router, don't intend to buy one. I have my ISP provided Teracom T2-B-Gawv1.4U10Y-BI model for connecting to the Net.
  • I have read up on using "Metrics" to assign "weights" to connectivity as recommended by many Microsoft MVP sites, but the responses in those threads make it clear that the method is very much "hit-and-miss". So, please suggest something else than the "Metrics" approach. Thanks.

Thanks in advance.

EDIT-I: I put my machine to sleep a while ago. Now, after wake-up, both Wired and Wireless show "Connected to Internet" once again. However, the strange thing here is, the laptop must be put to sleep before the Wired connection activates itself like this. Otherwise, it does not connect. Any other thoughts, in light of this?

EDIT-II: Scratch my above post (i.e., EDIT-I). We are back to the old behaviour of only one connection being used at any one time.... :(

share|improve this question
    
What are the connection speeds of your wired and WiFi connections? Does your laptop have a static IP address? –  w3d Jul 18 '13 at 11:37
    
Wired 100 Mbps Wireless 54 Mbps. No, my laptop uses DHCP/dynamic IP. Thanks. –  Surio Jul 18 '13 at 11:48

2 Answers 2

You can change the order, in which Windows connects to different network adapters, to do this go to the Network Connections window, there

  1. press Alt
  2. select Advanced > Advanced connections
  3. open the Adapters and Bindings Tab

There you can change the order of the network adapters, in your case, try placing your LAN connection to the top of the list, this should cause windows to use the braodband Ethernet connection when it's available and only go via wireless when not.

share|improve this answer
    
I did not mention it earlier, but these are some of the first obvious things I did. :). As of now, LAN/Wired is first in my list, but no joy for me! Thanks though. –  Surio Jul 18 '13 at 11:47
    
That's really strange, sorry it didn't work. –  who.knows Jul 18 '13 at 12:29
    
[deleted]... wrong thread –  Surio Jul 22 '13 at 16:19
    
Wow, I never noticed that menu before. I wonder what other menus have gone unnoticed now that they're hidden by default. I like the menu-less windows and have grown accustomed to it. –  Jeff Mercado Jun 14 at 1:59

I had a similar problem (access internet via ethernet cable or wireless). I disable the wireless access when using ethernet, and viseversa. It's a pain, but it works.

share|improve this answer
    
Hi! Thanks for dropping a line. My machine is dual boot, and if I hard disable wifi and forget about it before booting back into Linux, I have to reboot, log back, enable, reboot, log back..... which is all very annoying, and time-wasting.... Part of the reason why I am exploring for a cleaner solution to this problem. :) –  Surio Jul 22 '13 at 16:20
    
This is a good solution. Disabling/enabling must be done in device manager, without reboot and affecting Linux. Another laptop with buggy WiFi drivers had a similar problem (WiFi looses functionality sometimes), and this was the way to revive it. –  MKaama Apr 29 at 15:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.