Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem

After my IT department revoked - then re-granted - permission to use "Mass Storage Devices", my laptop's optical drive can no longer read DVDs or CDs. However, it appears to be able to write CDs and DVDs correctly.

Context

  • New laptop (3 months old)
  • Windows 7
  • Originally optical drive worked fine
  • IT department revoked "mass storage" which disabled both SD Card, USB, and DVD drive
  • At my request, IT department re-granted me permission to "mass storage" via the script below. According to our Windows guy, this should have made the DVD drive function again.
  • USB storage/SD Card now works, but optical drive cannot read DVDs or CDs.
  • I applied this 'Fix-It' from Microsoft: MicrosoftFixit.dvd.RNP.1502975461869821.1.1.Run.exe
  • I swapped the optical drive with a coworker's (also 3 months old) to check if I had a drive failure. The computer behaved the same with the other optical drive.
  • The computer can boot from the optical drive.

Additional oddities with optical drive

Some specific oddities with the optical drive:

  • It reads the "volume label" correctly (i.e. with the "Curious George" DVD, I see "CURIOUS_GEORGE" in the "Computer" window)
  • It appears to "write" correctly (i.e. Roxio burner successfully burned a CD. Note I did not test the resulting CD, however Roxio declared "success", whereas VLC and Windows Media Player fail noisily when trying to read)

Script

Our Windows guy supplied me with the following '.reg' code to restore "Mass Storage" . It worked to restore access to USB/SD cards, but not to optical drives.

Windows Registry Editor Version 5.00

[-HKEY_LOCAL_MACHINE\SOFTWARE\IBM\IGATEM]

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\RemovableStorageDevices\{53f56308-b6bf-11d0-94f2-00a0c91efb8b}]
"Deny_Execute"=-
"Deny_Read"=-
"Deny_Write"=-

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\RemovableStorageDevices\{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}]
"Deny_Execute"=-
"Deny_Read"=-
"Deny_Write"=-

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices]
"Deny_All"=-

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\{53f56308-b6bf-11d0-94f2-00a0c91efb8b}]
"Deny_Read"=-
"Deny_Write"=-

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}]
"Deny_Read"=-
"Deny_Write"=-

Any ideas on how to fix this?

share|improve this question
1  
Your IT guy is in the best position to figure out what the problm is. You should verify if you can NOT read the conetents of the disk you made. The best solution might be to simply reinstall Windows shoud take 2 hours at most for an experience IT person. –  Ramhound Jul 18 '13 at 17:12

3 Answers 3

up vote 2 down vote accepted
+100

I did a bit of research on this and I would tend to agree with FRob and Tiago that this is related to Group Policy and latent Registry entries, but since you are either a power user or local admin(inferred since IT had you run a .reg file).. I would suggest a simpler option.

Open computer management (hit the and type in "compmgmt.msc") then device manager and delete your CD/DVD drive. Then reboot. It will be re-installed and it will likely recreate any necessary registry key w/o you having to mess around in the registry or group policy. Deleting your DVD drive may sound drastic, but its really not a big deal. I assume you plugged the USB drive in and it installed drivers itself. It will do it again.

Good Luck,

Spencer

share|improve this answer
    
File under "W" for "Woohoo!" . This did it. I had tried the various registry tweaks. Disabling the DVD drive (note that windows 7 does not allow "delete") solved the problem –  user45705 Jul 23 '13 at 16:28
    
Glad to hear it lead you down the correct path. –  Spencer5051 Jul 23 '13 at 17:06

I observed similar behavior back with Windows XP when the syskey was damaged (by me using a 3rd party "Recovery CD" no less). The PC would complain that any disks (CDs only back then), USB storage devices were unreadable.

Also, concerning your registry file: The posted file is only supposed to re-enable access, so there is no telling what they did to disable it in the first place (other than putting the above keys/values there, maybe).

Notice how for GUID_DEVINTERFACE_CDROM (53f56308-b6bf-11d0-94f2-00a0c91efb8b) a value "Deny_All"/"Deny_Execute" would not be removed by this script if it was set before. So it might be worth checking out the above keys to see if any values that might possibly deny access survived.

Your IT department should have used a group policy to grant/deny access to removable media anyway, instead of providing a script that has to be run on each machine.

share|improve this answer

See if that works for you.

From technet:

Windows Registry Editor Version 5.00 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices] 
"Deny_All"=dword:00000000 
"RebootTimeinSeconds_state"=dword:00000000 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\Custom] 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\Custom\Deny_Read] 
"Deny_Read"=dword:00000000 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\Custom\Deny_Write] 
"Deny_Write"=dword:00000000 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\{53f56308-b6bf-11d0-94f2-00a0c91efb8b}] 
"Deny_Write"=dword:00000000 
"Deny_Read"=dword:00000000 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\{53f5630b-b6bf-11d0-94f2-00a0c91efb8b}] 
"Deny_Read"=dword:00000000 
"Deny_Write"=dword:00000000 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}] 
"Deny_Write"=dword:00000000 
"Deny_Read"=dword:00000000 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\{53f56311-b6bf-11d0-94f2-00a0c91efb8b}] 
"Deny_Write"=dword:00000000 
"Deny_Read"=dword:00000000 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\{6AC27878-A6FA-4155-BA85-F98F491D4F33}] 
"Deny_Read"=dword:00000000 
"Deny_Write"=dword:00000000 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\RemovableStorageDevices\{F33FDC04-D1AC-4E8E-9A30-19BBD4B108AE}] 
"Deny_Read"=dword:00000000 
"Deny_Write"=dword:00000000 

If the above does not work try this:

  • Open the Group policy editor(press enter image description here + R and type gpedit.msc, hit Enter).
  • In the left pane, click on User Configuration -> Administrative Templates -> System -> Removable Storage Access. (See screenshot below):

    enter image description here

  • In the right pane, right click on CD and DVD: Deny read access and click on Properties.
  • Select Disabled or Not Configured and click on OK.
  • Close Group Policy Editor window. Done.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.