Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hardware Details:

  • motherboard : ASUS p4p800s
  • CPU : Intel Pentium4 2.4GHz
  • HDD#1 : Western Digital WD800JB
  • HDD#2 : Seagate Barracuda 7200.7 ST340014A (40 Gbytes)
  • HDD#3 : Western Digital WD5000AAKB
  • videocard : Zotac 6200 ZT-62AAH2N-HSL
  • monitor : Samsung SyncMaster 940n

The Story So Far:

To start with, the system used to be dual-booting some version of ubuntu and some service pack of Windows XP. Then I got the bigger HDD#3, got a Dreamspark subscription and decided the time for a hardware/software update had come. It should have been simple: I backed everything up, swapped HDD#2 for HDD#3 and attempted to install Windows 8, which failed to boot from liveCD (I think the hardware is way too weak). So I threw this Windows idea away and proceeded installing ubuntu 13.04, which booted from liveCD fine, installed in the usual manner but, and here is the tricky bit, after installation booted into black screen. By black screen I mean POST goes fine but after that the screen goes completely black (no blinking cursor, no "Unable to locate bootable media" message, no nothing). Naturally, I googled all the easy places, but they all assume that the user can change something (kernel boot parameters and so on). Well, I tried various keyboard combinations to get out from this "black screen" state but to no avail. The only thing I can is get to BIOS from POST by hitting del (which is right before the system goes to black screen).

Attempted Solutions

At this point I realized there is a problem, so I tried to simplify it and get more data:

  1. Unplugged the HDD#3, leaving only HDD#1. Adjusted pins accordingly (these PATA drives need to be told who is master/slave and so on). Tried to boot - same result.
  2. Unplugged HDD#1, plugged HDD#3 back. Adjusted pins accordingly, installed ubuntu 13.04 on HDD#3 (again, liveCD boots fine, install goes ordinary). Booted to the very same black screen again.
  3. Plugged HDD#1 back, adjusted pins accordingly, installed Archlinux on both drives, wiping everything out beforehand. The story remained the same: Archlinux liveCD boots fine, installation goes fine, booting from hard drive leads to black screen right after POST. Again, no chance to change any kernel parameters, no messages, not responsive to a number of keyboard combinations (Ctr+Alt+F2 to get another console, for instance)
  4. Unplugged HDD#1, adjusted pins accordingly, freshly installed Archlinux to HDD#3. Same story
  5. Changed cable to the one from another machine I know to be working, attempted to boot. Same story.

Question

I know that by now some of you might be thinking "Hey, this guy doesn't know how to switch his monitor on". Well, unfortunately I do. I actually am hoping that I am missing out something very trivial. Does anyone have any idea what might be the problem that causes a completely black screen right after POST?

share|improve this question
1  
+1 for a well written question. Unfortunately since you are a new user, you can only include two links in your question. If you edit the question to add the missing links as simple text and then add a comment and ping me (@terdon) I would be happy to add the links in properly. –  terdon Jul 18 '13 at 16:20
    
Do you get the bootloader (where you choose OS) screen? That is where you will need to change options. –  terdon Jul 18 '13 at 16:22
    
"...but they all assume that the user can change something (kernel boot parameters and so on)". You can change things. You have liveCDs! Boot a liveCD, mount your hard drives, and make the changes. –  Brandon Invergo Jul 18 '13 at 16:22
1  
Can you try an older version of Ubuntu, or perhaps Puppy Linux/DSL? –  Karan Jul 18 '13 at 16:22
1  
Beep error codes are usually used before video has been initialized to report serious errors like malfunctioning CPU, completely bad or no RAM, no graphics card, etc. I would suspect either the IDE controller or the PATA cables. Since you already tried a different cable, that doesn't really leave many likely possibilities other than the controller, which unfortunately I'm afraid might mean the motherboard is broken. Here's to hoping someone else has something more positive. –  Michael Kjörling Jul 18 '13 at 19:10

3 Answers 3

I had this same problem the other day. Turned out to be the DVD drive. I replaced it with an old DVD-ROM drive and the problem went away.

share|improve this answer
    
not my case, the drive is used every time I boot from liveCD so I assume it is fine. –  all3fox Jul 18 '13 at 16:41
    
None of my problems pointed to the DVD drive. I replaced it out of desperation. –  Ray Cathode Jul 18 '13 at 16:54

You should be able to fix this by making sure GRUB is installed (or installing it if it isn't) and adding nomodeset to its options. You can find a nice tutorial for this here, the basic steps are reproduced below.

  1. First, you will need to boot into the live CD and then mount the drive where you have installed Linux. I will use /dev/sdXY but you should change that to whichever partition currently has an installed Linux system. So, mount your installed system from the Live CD:

    sudo mount /dev/sdXY /mnt
    
  2. Use chroot to switch into the mounted system:

    sudo mount /dev/sdXY /mnt
    
  3. Install (or update) GRUB to the MBR of your first hard drive::

    sudo grub-install /dev/sda
    sudo grub-install --recheck /dev/sdX
    
  4. Set the kernel parameters. You will need to edit the file etc/default/grub. IMPORTANT: make sure you edit the one that is in the mounted system under /mnt and not the one of the /etc directory on the Live CD. If you are still in the chroot environment, these commands will do what you need:

    sudo gedit etc/default/grub
    

    You should see something like:

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    

    Change the GRUB_CMDLINE_LINUX_DEFAULTline to

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
    

    Then save the changes:

    sudo update-grub
    

Now reboot and you should be OK.


I haven't installed Ubuntu in years but according to this page, you can set the kernel parameters during the install process, if you would rather reinstall than do the above you could try it:

enter image description here

share|improve this answer
    
yes, thanks, here is what I do in Archlinux: 1. boot from liveCD as root 2. '# mount /dev/sda1 /mnt', where /dev/sda1 is the partition I installed Arch to 3. 'arch-chroot /mnt' 4. edit '/etc/default/grub' to look like this GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" 5. run 'grub-mkconfig -o /boot/grub/grub.cfg' which gives me a reasonable grub.cfg 6. exit the chroot environment by 'exit' 7. 'unmount /mnt' and boot back to black screen. I believe these steps are similar to those above (except that I do not install grub - it's already there, I'm just changing the config) –  all3fox Jul 18 '13 at 18:08
    
what I mean to say: adding nomodeset doesn't seem to work. Moreover, I am beginning to believe I have a hardware problem: now I am hearing either 2 or 1 or 0 beeps even though I do not touch the hardware, which is strange. Anyway, thanks for you effort. –  all3fox Jul 18 '13 at 18:15
    
@all3fox ok, if you're getting beeps that is a different problem. However, after running grub-mkconfig you will need to run update-grub and grub-install /dev/sda for it to work. –  terdon Jul 18 '13 at 18:20
up vote 0 down vote accepted

Alright, since quite a few people took part in this discussion and for the sake of completeness I'll post the afterstory with answers. A friend of mine provided me with another ancient computer of his. By trial and error we figured out that both my Power Supply Unit and Motherboard were dead. Replacing those, I installed Puppy Linux as advised by @Karan. Neither Ubuntu 12.04 LTS nor Arch Linux agreed to install - for both of them kernel failed to load with "CPU 22 soft lockup bug", I did not investigate it further. I'm not expecting my new setup to work for long and looking for a complete replacement. Thanks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.