Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to be able to use two wireless network adapters on my RaspberryPi running wheezy (Debian).One card is to be used to connect to the network and I want the other to run in the monitor mode.

Two cards I'm using are identical: Dynamode WL-700N-RXS 150Mbps Nano 802.11n Wireless USB Adapter Dongle

Being a windows user this is getting a little out of my comfort zone and I would like to ask you for help with setting this up.

So far I tried using two dongles on my laptop under Network Security Toolkit and straight after the boot everything worked as I hoped for. Things started to get complicated for me when I tried to do it under Wheezy on RaspberryPi

  • First it didn't recognize any of the NIC under iwconfig but in lsusb i could see them but it looked like the both adapters have same MAC!
  • Google told me how to change the MAC under linux and now under iwconfig i can see wlan0 but no trace of wlan1

lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 148f:7601 Ralink Technology, Corp. 
Bus 001 Device 005: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

lsmod

Module                  Size  Used by
nfnetlink_log           8620  0 
nfnetlink               4929  1 nfnetlink_log
nfsd                   67106  0 
ipv6                  291230  30 
spidev                  5588  0 
arc4                    1387  2 
rt2800usb              12481  0 
rt2800lib              48137  1 rt2800usb
crc_ccitt               1553  1 rt2800lib
rt2x00usb              11851  1 rt2800usb
rt2x00lib              43907  3 rt2x00usb,rt2800lib,rt2800usb
mac80211              251866  3 rt2x00lib,rt2x00usb,rt2800lib
cfg80211              180452  2 mac80211,rt2x00lib
spi_bcm2708             4905  0 
i2c_bcm2708             3818  0 

ip link show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether b8:27:eb:6d:7c:ed brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether 30:54:38:a7:fa:5d brd ff:ff:ff:ff:ff:ff

ifconfig -a

eth0      Link encap:Ethernet  HWaddr b8:27:eb:6d:7c:ed  
          inet addr:192.168.1.143  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::ba27:ebff:fe6d:7ced/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:704 errors:0 dropped:0 overruns:0 frame:0
          TX packets:159 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:41614 (40.6 KiB)  TX bytes:21456 (20.9 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 30:54:38:a7:fa:5d  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

# wlan0
auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
# change mac
pre-up macchanger -m 30:54:38:A7:FA:5D wlan0

# wlan1
auto wlan1
share|improve this question
    
Disconnect wlan1, connect again and provide dmesg | tail -90 output. –  september Jul 18 '13 at 20:01
1  
"Two cards I'm using are identical" - it is not correct, according your lsusb output. –  september Jul 18 '13 at 20:13

1 Answer 1

up vote 1 down vote accepted

september is right that they are not identical 148f:5370 and 148f:7601 identifies usb vendor and usb product (e.g. you can see Linux supported usb devices on this link, although it is not a complete list). So that they are from the same vendor but not the same usb devices anyway.

On the above link and lsusb says that 148f:5370 uses RT5370 chipset. Debian's wiki page says that chipset uses rt2800usb driver. The lsmod output shows that your Debian has rt2800usb, that's why you don't have any problem with that device and can use it as wlan0.

However, I couldn't find chipset of 148f:7601. However, http://support.dynamode.com/wireless-devices/wireless-usb/wl-700n-rxs/ says that it uses Realtek 8188SU chipset. Again referring the Debian's wikipage:

Debian 7.0 "Wheezy" This release supports Realtek RTL8188CE, RTL8188CUS, RTL8188DE, RTL8188SU, RTL8191SE, RTL8191SU, RTL8192CE, RTL8192CU, RTL8192DE, RTL8192E, RTL8192SE, RTL8192SU and RTL8192U-based devices.

1) Add a "non-free" component to /etc/apt/sources.list, for example:

deb http://http.debian.net/debian/ wheezy main contrib non-free

2) Update the list of available packages and install the firmware-realtek package: sudo apt-get update && apt-get install firmware-realtek

RTL8192U-based devices only: firmware is required to be manually supplied:

sudo apt-get install unzip && exit

wget ftp://ftp.dlink.com/Wireless/dwa130_revC/Drivers/dwa130_revC_drivers_linux_006.zip

unzip dwa130_revC_drivers_linux_006.zip $ su

sudo mkdir -p /usr/local/lib/firmware/RTL8192U

sudoo cp rtl8192u_linux_2.6.0006.1031.2008/firmware/RTL8192U/* /usr/local/lib/firmware/RTL8192U

3) Connect the device to your system.

4) Configure your wireless interface as appropriate.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.