Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am not sure what I need to do, if anything. Using CentOS, when I run service mysql stop, it stops MySQL.

On openSUSE studio, when I run the same command, it does not work.

share|improve this question

1 Answer 1

One solution to your problem is to setup mysql as a service. In the mysql installation tarball, there should be a script called mysql-server (or something similar). Copy that to /etc/init.d and name it mysql (you may need to edit it, so that the mysql user is the same as the one you setup on your system and that the path to mysql is the same as the one on your system). After that run the following commands:

# chkconfig --add mysql
# chkconfig mysql on

You'll then be able to manage mysql using the service command e.g.

service mysql start
service mysql stop
service mysql status

Hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.