Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a truecrypt volume generated on osx. I don't remember which filesystem type I chose, but I think it was macosx extended.

I am trying to access this disk from linux ubuntu 12.02, but unfortunately I can't get it to mount. Truecrypt opens the volume without problem, but when it's time to mount, it complains about some NTFS stuff (like it's trying to mount a NTFS volume). I don't have the exact error message with me unfortunately.

What I have tried:

  • I don't think the filesystem is ntfs. I think that mount does not recognize it and "guesses" wrong. Probably it's HFS+.
  • I tried to identify the filesystem type, with either file, parted, or many other suggestions from first shot googling. I could not come up with a definitive answer.
  • I of course installed hfsprogs and tried to mount it with mount -t hfsplus, but it still does not mount it.

It would be really helpful if anyone could try to make a small encrypted partition on mac and try to mount it on linux, and see if it works.

Thanks

share|improve this question

You must log in to answer this question.

Browse other questions tagged .