Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I switched my windows 7 pc on today I was unable to access the web. I am able to ping websites, but firefox, ie, msn etc fail to load a page. Some programmes crash with a socket error when I attempt to connect - e.g. msn

windows 7 detects the router. I am able to ping google, bbc etc I am able to access web pages by firing up an ubuntu VM.

this suggests that there is something in windows actively preventing my connecting to the internet so I:

  • uninstalled livemesh
  • uninstalled windows security essentials (I had uninstalled pc tools antivirus the day before and installed windows security eseentials if its relevant)
  • removed my network card and reinstalled the driver

but it still doesn't work

any suggestions?

share|improve this question
do you use a proxy server? – shufler Oct 28 '09 at 20:18
no - just dsl via a router. – frankster Oct 28 '09 at 20:55
Same problem, still cannot figure out what is causing it. Reboot restores internet access. – BanditoBunny Nov 20 '12 at 22:28

Uninstall antivirus software. I've seen this problem when 2 antivirus programs are installed.

Change your DNS settings to OpenDNS.

Good luck.

share|improve this answer
dns resolution works - I can ping google etc. I have onyl had 1 antivirus installed at a time... i uninstalled pc tools yesterday cos its buggy in windows 7, then replaced it with windows security essentials. then noticed today that i couldnt access the web any more. – frankster Oct 28 '09 at 20:52
I made this mistake too when trying to switch AntiVirus providers. In trying to make sure I didn't leave the machine unprotected I installed the new AV before uninstalling the old and then spent half an hour wondering why I couldn't get out onto the web. Considering I wouldn't have actually been surfing during the period when there was no AV installed, my precautions weren't even necessary. – ChrisF Oct 28 '09 at 20:55
up vote 2 down vote accepted

After uninstalling, resetting winsock allowed internet access again:

as administrator, run "netsh winsock reset" (one way to run as administrator is make a shortcut on your desktop to the command then right-click the shortcut and select run as administrator)

share|improve this answer

You might need to train the firewall part of Windows Security Essentials to let browsers out. Though I would have thought it would have asked the first time you used a new program.

Try turning the firewall off, then try to browse to somewhere safe (e.g. google or the bbc). If that works then it is the firewall that's blocking. If not, the problem lies somewhere else.

Don't forget to turn the firewall back on, and don't browse anywhere else while it's off.

share|improve this answer
I disabled the firewall and it doesn't make any difference :( – frankster Oct 28 '09 at 21:18
@frankster - sorry, but I can't think of anything else to try at the moment. – ChrisF Oct 28 '09 at 21:27

I reinstalled pc-tools anti-virus and I was able to access the internet again.

Therefore I wouldn't recommend installing this programme on windows 7, but if you already have it installed I definitely wouldn't recommend uninstalling it! ;)

share|improve this answer
i tried uninstalling it again today and the same symptoms occurred, so I put it back on. It seems pc-tools has my internet access hostage! – frankster Nov 3 '09 at 9:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .