Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I edit any random text file in GNU emacs 24.3.1 in fundamental mode, it tries to match quotes and change the color of the text between them. This is fine if the file contains English text, but I'm frequently editing files containing random ASCII characters and the random coloring is very distracting. This did not happen with emacs 22.1.

How can I turn this off for fundamental mode? I'd like to keep it for other modes like C, python, etc.

This is on Windows if that matters.

share|improve this question
1  
There is no hook for fundamental mode, so one idea would be to enable font lock for specific modes (with add-hook) and turn it off globally: gnu.org/software/emacs/manual/html_node/emacs/Font-Lock.html Another option might be use a change mode hook to trigger turning off font lock in fundamental mode, however, that wouldn't resolve the situation of opening files that default to fundamental mode. The quote matching is a different animal and I'll let another fellow poster address that issue, and/or improve upon the font-lock answer. –  lawlist Jul 22 '13 at 1:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.