Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently disabled the graphical login manager on my Ubuntu and started using startx. But when the computer turns on, instead of giving me a login prompt in one of the TTYs (I think that's how you call the terminals in Ctr+Alt+F1 and so on), it shows the display where X runs (the Ctrl+Alt+F7 one), and so I have to switch back to another one to be able to login.

It is only a minor annoyance, but does anyone know how I can make it boot directly into the first TTY?

share|improve this question
    
Did you update /etc/inittab to disable the graphical login manager, or something else? – nerdwaller Jul 19 '13 at 13:32
    
I just uninstalled it. I don't have that file in my system. – Caetano Sauer Jul 19 '13 at 15:48
up vote 1 down vote accepted

According to this forum post, this is a bug in the install CD. To fix it and change your default tty from tty7 to tty1, you need to edit the GRUB configuration file /etc/grub.d/10_linux.

In this file, find the location where the vt_handoff variable is set, and modify the value to 1 instead of 7 (you should see something like set vt_handoff=vt.handoff=7 already). Note you will need root to do this so you'll need to edit it with sudo.

Once this is done, update GRUB with the new configuration (sudo update-grub), and reboot.

share|improve this answer
    
Yup, that did it. Thank you! – Caetano Sauer Jul 19 '13 at 15:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .