Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to be able to boot into windows from grub. If I select the windows hdd from the bios boot options, I can get in no problem, so the windows bootloader seems to still be intact. I have tried the following in /etc/grub/40_custom (followed by update-grub):

menuentry "Windows 7 (loader)" {
    set root=(hd0,1)
    chainloader +1
}

I have tried multiple combinations of set root=(hdx, y) but I keep getting errors along the lines of 'the partition doesn't exist.

fdisk -l results are:

   Device Boot      Start         End             Blocks       Id      System
/dev/sda1   *        2048      206847         102400       7  HPFS/NTFS/exFAT
/dev/sda2          206848   175833087    87813120    7  HPFS/NTFS/exFA

I don't know if this is related, but I am also running into some strangeness that I have never seen before. I have linux and grub installed on one disk (encrypted lvm) and windows installed on a separate disk. If I unplug my windows disk, so that the linux disk is the only thing plugged into the system, and then go to the boot order from the bios, I see the disk name, as well as a separate bootable option called 'debian'. If I try to boot from the disk it complains about grub not working (will update with exact error), but if I try to boot from the debian option then I get my grub, and can get into the linux os no problem. If I unplug the linux hdd, that debian option disappears from the boot menu. What would cause that, and could it be related?

share|improve this question

migrated from serverfault.com Jul 20 '13 at 2:33

This question came from our site for professional system and network administrators.

add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.