Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For this task some bootable USB stick drives are available, but the CD drive is broken without near chances to get a new, so can not cdimage burn and boot. Machine (Dell Latitude C400) does not seem to allow USB boot, even being a many featured machine. I have Internet broadband, floppies drive and a huge lot of floppies, but no high density floppies formatting background.

Already tried bgrescue-3.0.0 and bootgrub using dd.exe to dump the images to some floppies but didn't help trying to boot my USB stickdrives. bgrescue-3.0.0 told image is not correct, but then downloaded Python33 and used it to test the sha1 sums with hashlib ending in a sha1 OK match. bootgrub worked great and started with its defaults hda and hdb. hda got mapped to the hard disk drive, and hda1 to its XP partition, but hdb did not got mapped to the USB bootable stick (credited LinuxLive USB Creator). Could not tomsrtbt-2.0.103.dos'ed it nor picoboot-0.95'ed it because of my lack of high density (is that 1722ko format what they called HD?) floppies format understanding.

Later managed to loadlin-1.6f.exe a kubuntu 12.04.2 USB stick drive's vmlinuz. After deleting a bunch of software shit, created a FAT32 drive in some allocated space. Then put there the contents of the USB Linux Live stick, booted a DOS rescue and did the C:\loadli~1 casper\vmlinuz.

That finally booted GNU/Linux, which was great, for a while. Then, panicked like this:

[1.349018] md: Scanned 0 and added 0 devices.
[1.349061] md: autorun ...
[1.349100] md: ... autorun DONE.
[1.349283] VFS: Cannot open root device "(null)" or unknown-block(0,0)
[1.349331] Please append a correct "root=" boot option; here are the availab
le partitions:
[1.349413] 0800   29302560 sda driver: sd
[1.349482]  0801  10490413 sda1 00000000-0000-0000-0000-000000000000
[1.349555]  0802  18804082 sda2 00000000-0000-0000-0000-000000000000
[1.349625] Kernel panic - not syncing: VFS: Unable to mount root fs on unkno
wn-block(0,0)
[1.349693] Pid: 1, comm: swapper/0 Not tainted 3.2.0-37-generic-pae #58-Ubun
tu
[1.349754] Call Trace:
[1.349810]  [<c15922ab>] ? printk+0x2d/0x2f
[1.349859]  [<c1592179>] panic+0x5c/0x161
[1.349911]  [<c1879b6a>] mount_block_root+0xb9/0x14c
[1.349964]  [<c115353c>] ? sys_mknod+0x2c/0x30
[1.350012]  [<c1879d75>] mount_root+0x59/0x5f
[1.350060]  [<c1879ec9>] prepare_namespace+0x14e/0x192
[1.350110]  [<c11440e5>] ? sys_access+0x25/0x30
[1.350158]  [<c18798de>] kernel_init+0x156/0x15b
[1.363001]  [<c1879788>] ? start_kernel+0x353/0x353
[1.363298]  [<c15afafe>] kernel_thread_helper+0x6/010
_

Interpreted this as a failure because of booting an USB vmlinuz outside its natural environment.

Finally used the Internet search engines looking for a more generic super vmlinuz package, but in kernel.org only found sources am not probably able nor gutted to compile.

At this point am looking for help before diving into searching about the panic messages and working around that root boot issue.

I wonder would be possible to boot GNU/Linux here before getting an opportunity to change broken CD drive when back in town? Think VMs won't pay off being a severely corrupted XP system.

share|improve this question

closed as unclear what you're asking by Canadian Luke, Breakthrough, Shekhar, Scott, Darth Android Aug 7 '13 at 20:49

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers 3

Interpreted this as a failure because of booting an USB vmlinuz outside its natural environment.

Your interpreter should read this again:

Please append a correct "root=" boot option; here are the available partitions:
 0800   29302560 sda driver: sd
 0801  10490413 sda1 00000000-0000-0000-0000-000000000000
 0802  18804082 sda2 00000000-0000-0000-0000-000000000000

Assuming sda1 is the boot partition, try appending root=/dev/sda2 to the kernel command line.

share|improve this answer
    
Guess you guessed right that /dev/sda2 is the FAT32 where the booted vmlinuz lies. After doing this, seems that kernel tried to mount it using ext3, ext4 and fuseblk, and now the panic is in general terms similar, but now the unknown-block(0,0) part is showing as unknown-block(8,2). Answering your question No external installation mediums possible, can I boot this kernel through loadlin? the naïve answer seems to me an eagerly, no. Guess later will read more about loadlin and vmlinuz checklists and compatibility. Thanks btw. –  galegosimpatico Jul 20 '13 at 10:30
    
@uprego: You could try to append rootfstype=vfat as well if it can't determine it at first; if not, you'll have to compile (or find, but that might take a while) yourself a new kernel with support for it. –  Tom Wijsman Jul 20 '13 at 10:32
    
This loadlin.exe seemed not to have rootfstype option. Created a 3rd part. (ext3) using a pqmagic.exe from DOS rescue and 2nd part (FAT32). Then after i tries found C:\KUBUNT~1\CASPER>..\..\loadli~1.exe vmlinuz root=/dev/sda3 rw initrd=initrd.lz seemed to be a fair call with this kernel in this machine. With this, system booted up to a neverending dark screen. Had Ctrl+Alt+Del now. Having several USB sticks, finally tried another. Guess what, C:\DEBIAN6\INSTALL.386>..\..\loadli~1.exe vmlinuz root=/dev/sda3 rw initrd=initrd.gz let it to the install TUI! Installed almost as smooth as usual. –  galegosimpatico Jul 20 '13 at 15:51

I've had great success booting usb on older hardware whose BIOS did not even support booting from usb using plop boot manager.

share|improve this answer

USB boot is extremely problematic with these old Latitudes, because the USB controller is not properly initialized by BIOS at all. So, the bootloader is faced with having to try to boot off half-initialised hardware and with the part of the initialisation that is done being just the bare essentials needed to get XP to boot.

It is a major problem to get any Linux running on it, even from a CD boot.

That laptop is a ancient P3 with 256 MB RAM. It might have been the expensive version at the time with 512 MB. Modern Linux distros (except for DSL, Knoppix, Puppy or other bare bones mini-distros) will be severely struggling to work on it anyway. Your phone is probably faster and has more RAM.

share|improve this answer
    
This answer is full of rant and therefore not constructive; it does not even reflect the error in the question, therefore it's not based on facts and references, and rather on false assumptions and hatred. –  Tom Wijsman Jul 20 '13 at 10:10
    
@TomWijsman Rant ? Facts my friend. I had to support running Linux on these things years ago. Eventually we just sold them off and bought IBM laptops. It just wasn't worth the time/effort/money to try getting things to work on these. Even if we got it working the next kernel-update would cause all sort of mayhem and we could start all over again. –  Tonny Jul 20 '13 at 10:14
    
Please refer me to these facts. –  Tom Wijsman Jul 20 '13 at 10:15
1  
Actually it is one of the 512Mib RAMsized! I was hoping to use it as a replacement for a Compaq Presario 700 (no factsheet found sorry, but 256Mib) secondary laptop that is running LXDE over the bleeding edge... but still works fine for not flashrelated tasks. –  galegosimpatico Jul 20 '13 at 10:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.