Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just started using New Relic. It didn't display properly in IE9, so I installed IE10. When I start the New Relic site, I am presented with the same display errors and the error message:

We've noticed that you're running Internet Explorer in compatibility mode. The New Relic site works best with a modern browser. Please turn off compatibility mode for a better experience.

The display errors are that two columns of data are overlapped, the second one partially covering the first, and rendering both of them unreadable.

There's no Compatibility Mode button available in the address bar. In the options, I can add sites to be displayed in Compatibility Mode, not prevent them from such.

How do I disable Compatibility Mode for the New Relic website in IE10?

share|improve this question

migrated from webapps.stackexchange.com Jul 20 '13 at 9:19

This question came from our site for power users of web applications.

    
When I opened the website today it looked correct. Maybe I had a caching issue instead? –  Hand-E-Food Jul 11 '13 at 22:57

1 Answer 1

up vote 2 down vote accepted

There is a button on the right side of the address bar, it looks like a ripped document:

enter image description here

When the button looks pressed, the site is rendered in compatibility mode:

enter image description here

I think the message on New Relic is wrong. They don’t even allow compatibility mode, because they have this snippet in their markup:

<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

This is why you don’t see the button: the tag forces IE to run in normal mode. You can check this for yourself: press F12, this open the developer tools. There you can see the exact current rendering mode:

enter image description here

share|improve this answer
    
Thanks. I know the button you mean, I can see it on this page (Stack Exchange.) Unfortunately it does not appear when I'm on the New Relic website. –  Hand-E-Food Jul 11 '13 at 5:38
    
@Hand-E-Food See my update. –  toscho Jul 11 '13 at 5:51
    
Thanks for that! When I opened the website today it looked correct. Maybe I had a caching issue? At least I'm confident I don't have Compatibility Mode erroneously turned on. Thanks! –  Hand-E-Food Jul 11 '13 at 22:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.