Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wiped a 180GB not that long ago and I recently went to use it again; it is attached to my computer as an External HDD. When I bring up Disk Management in Windows (7) I receive a message stating that the device must be initialized; when I try and do this it throws an error: The Disk is write-protected. I have seen numerous articles on this topic but none of the suggestions so far have helped; specifically a method involving editing the registry in an effort to disable write protection. It has occurred to me that it may be feasible to boot into a Linux boot DVD and use Linux to wipe the drive; however I have not attempted this yet. I have tried connecting this to another machine and same error.

share|improve this question
    
Does it by some chance have a hardware switch or go to Properties>Security you have R/W access? –  ekaj Jul 20 '13 at 23:23
    
No there is no hardware switch. There is also no Security reference as the harddrive is recognized but not initialized. –  Gedalya Jul 20 '13 at 23:34

2 Answers 2

Try using diskpart.exe - find your disk with list disk, then select it with select disk and see if attribute disk clear readonly works.

As far as why this would get set, beats me.

share|improve this answer
    
Thanks for your suggestion; I attempted the steps you recommended with diskpart.exe. It failed with the following message: > DiskPart failed to clear the disk attributes. –  Gedalya Jul 21 '13 at 2:54

As the disk is already wiped, you might try the manufacturer's diagnostic and/or formatting software. IIRC both Seagate and Western Digital offer software that will low level format their drives and this might be the answer to this. You might do well to run the diagnostics software on this drive in any case as IME I would suspect a bad drive.

If the above does you no good, you might do well to try HiRen's Boot Disk as it contains many utilities for just this purpose. The most recent version I recall is Volume 15.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.