Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My installation of Windows 7 has been having some issues. Aero refuses to work (Microsoft's FixIt tool says my video card (a GTX 260) isn't capable of it, even though it's worked fine for years), Calculator doesn't render correctly and the Windows Photo Viewer refuses to display pngs (saying the file "appears to be damaged, corrupted, or is too large"). I tried uninstalling and reinstalling graphics card drivers, including older versions, to no avail.

enter image description here

Suspecting all hope of a proper fix lost, I tried to do a repair install, but the installer claims a compatibility error:

To upgrade Windows, the Users, Program Files, and Windows directories need to be on the same partition. Upgrading when these directories are not on the same partition is not supported. Moving these directories so that they are on the same partition is also not supported. You can choose to install a new copy of Windows 7 Enterprise instead, but this is different from an upgrade, and does not keep your files, settings, and programs. You’ll need to reinstall any programs using the original installation discs or files. To save your files before installing Windows, back them up to an external location such as a CD, DVD, or external hard drive. To install a new copy of Windows 7 Enterprise, click the Back button in the upper left-hand corner, and select “Custom (advanced)”.

Even though those three folders are on the same partition, and always have been. I even tried unplugging my other hard drive and it still throws the same message.

Is there a way out of this without a clean install?

share|improve this question
    
My first question is are you actually running Windows 7 Enterprise? –  Ramhound Jul 23 '13 at 11:26
    
I am. I guess I forgot to say that. –  lowpass Jul 23 '13 at 13:25

1 Answer 1

up vote 0 down vote accepted

... Figures that almost immediately after posting here, I'd stumble upon a working solution. Per this random forum's thread I tried uninstalling KB2670838 and rebooting, and I got Aero back. Amazingly enough the other two problems were also apparently related, as I have a functional Calculator again, and Photo Viewer displays PNGs just fine.

Edit: Should note that I'm not sure if this also fixed the repair install issue, but I'm not going to bother trying.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.