Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am following instructions in http://blog.oberghmans.be/?p=71 to nat my wireless connection with some pc's that cant be connected to the router with a wired connection, using a Dlink DWA-525 Wireless N 150 Desktop adapter.

The wireless interface associates with the accesspoint and i can browse the internet from the computer. However nat does not seem to be working.

Given below is the ping output

ping -I eth0 8.8.8.8
PING 8.8.8.8 (8.8.8.8) from 10.1.1.1 eth0: 56(84) bytes of data.
From 10.1.1.1 icmp_seq=1 Destination Host Unreachable
From 10.1.1.1 icmp_seq=2 Destination Host Unreachable
From 10.1.1.1 icmp_seq=3 Destination Host Unreachable

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 3014ms
pipe 3

And the iptables output

Chain PREROUTING (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 33 packets, 2098 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain POSTROUTING (policy ACCEPT 3 packets, 252 bytes)
 pkts bytes target     prot opt in     out     source               destination         
   30  1846 MASQUERADE  all  --  *      wlan0   0.0.0.0/0            0.0.0.0/0 

Any help regarding the issue would be greatly appreciated.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.