Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to dual boot my new Acer V5-122p with the pre-installed Windows 8 and Linux Mint 15 Mate. The laptop doesn't have a DVD drive, so I have to boot through USB. When I boot Mint in UEFI mode, the Mint logo appears as if it's going to work, but then it just goes to essentially a command line($) and gives me an error saying, "Failed to start the X server (your graphical interface). It is likely that it is not set up correctly. Would you like to view the x server output to diagnose the problem?" It basically ends telling me, "The x server is now disabled. Restart MDM when it is configured correctly." I thought this might be being caused by Secureboot, but I've disabled that and it still does the same thing. If I boot it in Legacy mode, then it works fine. Problem is, I have to install in UEFI mode, because that's how Windows 8 is installed. I've also tried booting it on another computer, then running all the updates to see if it would help and no luck there either. Compatibility mode also doesn't help. The command, startx, also does not work. It gives me an error saying, "no screens found" and "xinit:unable to connect to x server: Connection refused." I've also tried Ubuntu and Fedora, and the same thing happens.

I've really tried to figure this out myself, but I'm at the end of my abilities. Does anyone have any ideas or advice on how I should go from here?

share|improve this question
Your question isn't clear. Its a single long statement not even broken up. You didn't explain what tool you used to create the UEFI bootable device. Are you using MBR or GPT partitions?( I know what you should be using just attempting to verify thats the case.) – Ramhound Jul 24 '13 at 11:49
I actually kind of like this question. Even thou it's vague. What is your kernel version? – Ben Plont Jul 24 '13 at 21:22
I apologize for the vagueness. I just don't know enough to know what to ask. I used Unetbootin to create what I hope is a UEFI bootable device. – Joe Jul 24 '13 at 23:44
As far as the kernel version, here is what I hope is that information: Linux version 3.8.0-19-generic (buildd@allspice) (gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1) ) #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 Thank you both for your responses. – Joe Jul 24 '13 at 23:47
Also tried the the steps from the following link to create a GPT partitioned USB Bootable device, unfortunately to the same result:… – Joe Jul 25 '13 at 2:42

The first thing I would try in this situation is updating the BIOS on your computer. It sounds like there is a conflict between the built in UEFI graphics driver and the OS graphical interface. A new bios package may contain a fix for this. From what I understand and what you have tested so far I believe we can safely eliminate the USB stick and secure boot as the cause of your problem. After a BIOS update my next idea would be to install the os without a GUI, then install the latest graphics drivers (you may need to try the proprietary drivers).

share|improve this answer

You must be in CSM to boot into a linux kernal as of now, so just backup important stuff on windows 8, then reinstall windows 8 in CSM mode. Then reinstall linux in CSM mode, and then you successfully got a dual booting machine.

Edit: To be properly in CSM mode, enable Legacy Boot and disable Secure Boot.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.