Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have TP LINK TD-8817 as my ADSL Router, and TP-LINK TL-MR3420 as Wifi Router.

I've done to open port 80, based on this result

*please see this picture

enter image description here

and the problem is : when I access my public IP, 125.xxx.xxx.xxx:80

it's still returning to my router port. (I expected it'll return to my computer ip port, 192.168.0.102)

*please see this picture

enter image description here

=======================:

 IPv4 Address. . . . . . . . . . . : 192.168.0.102(Preferred)
 Subnet Mask . . . . . . . . . . . : 255.255.255.0
 Lease Obtained. . . . . . . . . . : 24 Juli 2013 15:34:29
 Lease Expires . . . . . . . . . . : 24 Juli 2013 21:34:06
 Default Gateway . . . . . . . . . : 192.168.0.1
 DHCP Server . . . . . . . . . . . : 192.168.0.1

======================= And here my forwarded port (ADSL Modem)

Rule     Application     Protocol    Start Port  End Port    Local IP Address
1            HTTP_Server    ALL         80          80         192.168.1.100
2            HTTP_Server    ALL         443         443        192.168.1.100

======================= On Wifi Router

   ID   Service Port    Internal Port   IP Address  Protocol    Status  Modify
1        80                 80        192.168.0.102     All          Enabled    Modify Delete

=======================

and I have no idea how to resolve this. I appreciate any help thank you.

share|improve this question
    
The results you are getting are to be expected based on your current configuration. Why are you forwarding traffic on port 80 to both 192.168.1.100 and 192.168.1.102? that does not seem right. Your current configuraton is attempting to access the http server of the modem itself hence the prompt. If you were to input your username and password to your modem you would be redirect not to your http server on .102 but to the internal http server of the modem. –  Ramhound Jul 24 '13 at 15:00

1 Answer 1

up vote 0 down vote accepted

Your ADSL router already uses the TCP80 port for its remote administration interface.

From here you have 2 solutions :

1) Change Router interface port

If you can find any parameter in your router's configuration for this, change it to, for example, 8080. After that your NAT should work fine.

2) Change your external HTTP port

If your router does not support the modification of its remote interface TCP port, you will have to choose another port for your website, which is often unwanted.

In your port forwarding settings, change this :

Rule     Application     Protocol    Start Port  End Port    Local IP Address
1            HTTP_Server    ALL         80          80         192.168.1.100

To this :

Rule     Application     Protocol    Start Port  End Port    Local IP Address
1            HTTP_Server    ALL       8080        8080         192.168.1.100

And this :

ID   Service Port    Internal Port   IP Address    Protocol   
1       80              80        192.168.0.102     All

To this:

ID   Service Port    Internal Port   IP Address    Protocol   
1     8080              80        192.168.0.102     All
share|improve this answer
    
thank you, yes I tried that way too. but doesn't work. I don't know what is wrong. –  Richard Octovianus Jul 24 '13 at 17:43
    
Have you tried accessing it from an external device ? Some SOHO routers don't have a loopback interface and are unable to query themselves... –  Kwaio Jul 25 '13 at 7:24
1  
Yeah!!! Finally works. I just realize that, thank you Kwaio! –  Richard Octovianus Jul 25 '13 at 8:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.