Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there any solution to run fedora 19 on my laptop (Asus x61s) without acpi=off set and removing power management controll? If I remove this option, system hangs just after start booting. I never had this issue with ubuntu, so I guess it's possible.

$ uname -a
Linux 3.9.9-302.fc19.x86_64 #1 SMP Sat Jul 6 13:41:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ sudo lshw -short
H/W path        Device      Class       Description
===================================================
                            system      F50SL (To Be Filled By O.E.M.)
/0                          bus         F50SL
/0/0                        memory      64KiB BIOS
/0/4                        processor   Intel(R) Core(TM)2 Duo CPU     T6400  @ 2.00GHz
/0/4/5                      memory      64KiB L1 cache
/0/4/6                      memory      2MiB L2 cache
/0/23                       memory      4GiB System Memory
/0/23/0                     memory      2GiB DIMM SDRAM Synchronous
/0/23/1                     memory      2GiB DIMM SDRAM Synchronous
/0/100                      bridge      671MX
/0/100/1                    bridge      PCI-to-PCI bridge
/0/100/1/0                  display     RV710/M92 [Mobility Radeon HD 4530/4570/545v]
/0/100/1/0.1                multimedia  RV710/730 HDMI Audio [Radeon HD 4000 series]
/0/100/2                    bridge      SiS968 [MuTIOL Media IO]
/0/100/2.5                  storage     5513 IDE Controller
/0/100/3                    bus         USB 1.1 Controller
/0/100/3.1                  bus         USB 1.1 Controller
/0/100/3.3                  bus         USB 2.0 Controller
/0/100/4        em1         network     191 Gigabit Ethernet Adapter
/0/100/5                    storage     SATA Controller / IDE mode
/0/100/6                    bridge      PCI-to-PCI bridge
/0/100/6/0      wlp2s0      network     AR928X Wireless Network Adapter (PCI-Express)
/0/100/7                    bridge      PCI-to-PCI bridge
/0/100/f                    multimedia  Azalia Audio Controller
/0/1            scsi2       storage     
/0/1/0.0.0      /dev/sda    disk        250GB Hitachi HTS54322
/0/1/0.0.0/1    /dev/sda1   volume      100MiB Windows NTFS volume
/0/1/0.0.0/2    /dev/sda2   volume      48GiB Windows NTFS volume
/0/1/0.0.0/3    /dev/sda3   volume      146GiB Windows NTFS volume
/0/1/0.0.0/4    /dev/sda4   volume      37GiB Extended partition
/0/1/0.0.0/4/5  /dev/sda5   volume      1952MiB Linux swap / Solaris partition
/0/1/0.0.0/4/6  /dev/sda6   volume      35GiB Linux filesystem partition
/0/2            scsi3       storage     
/0/2/0.0.0      /dev/cdrom  disk        DVD-RAM UJ870BJ
/0/3            scsi4       storage     
/0/3/0.0.0      /dev/sdb    disk        SCSI Disk
share|improve this question
1  
Try using acpi=rsdt and/or nomodeset. –  harrymc Jul 29 '13 at 17:03
    
You have latest BIOS/UEFI version? Also,the model of your laptop. And, can you boot using a LiveCD? –  Braiam Jul 30 '13 at 19:31
    
Why are you setting these options in the first place? What happens if you simply remove both acpi and nomodeset? –  terdon Aug 1 '13 at 16:00
    
@terdon If I remove this option, system hangs just after start booting. I had to set it to install system at all. –  Kiro Aug 1 '13 at 16:35
    
@harrymc It didn't help –  Kiro Aug 1 '13 at 16:44

2 Answers 2

up vote 1 down vote accepted
+100

As said in this bug report, and following the conclusion made of this comment, you are not able to boot since Fedora introduced a possible regression (in my opinion) to the kernel. Two solutions are possible:

  • Downgrade the kernel
  • Make the changes in the grub.conf, so you don't have to manually add it each time you boot.

In either case you should subscribe to the bug report so you get notified when it's fixed. This also reflects the impact of a bug, so Fedora developers can focus on this kind of bugs.

share|improve this answer

Here is a short description for Ubuntu. I think it will be useful in your case.

share|improve this answer
    
It's about change bios settings to run ubuntu. But Ubuntu was working without requiring change any bios settings. So it's possible, and this is why I looking for a solution that won't affect my other OS. –  Kiro Jul 26 '13 at 10:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.