Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

All of the sudden my XP laptop will not go into standby mode. I tell it to standby but it just continues to run. Same with hibernate. I have not added any hardware, but I did kill a software installation (long story). Is there some registry entry that blocks standby/hibernate? I can shutdown successfully.

Edit 2009-10-29:
After examining the System Events, I find the following Warning whenever I try to standby:

A request to suspend power was denied by svchost.exe.

And here's the data that goes along with it:

0000: 00 00 00 00 02 00 4e 00   ......N.
0008: 00 00 00 00 f0 00 00 80   .......€.
0010: 00 00 00 00 00 00 00 00   ........
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........

Edit 2009-10-29 PM: A solution (of sorts)
Thanks to everyone who posted a possible solution. It was Andy who gave me the tip I needed. I ended up stopping every service on my PC (and since I'm a Corporate Drone, there were a ton of them). I got down to almost no services (and my computer was amazingly snappy -- but that's beside the point). But still no joy.

I finally started killing off svchost.exe processes using Process Explorer, and when I got to the one running a bunch of services (that I thought I had stopped, but they still showed up in process explorer's hover-view), bam a piece of Corporate Drone software started installing in the foreground. I canceled the install and lo-and-behold my computer went into standby mode when I told it to.

Here's what I think happened -- I must have interrupted some invisible Corporate Drone installer the other day when I went postal on a bunch of CPU eating software when I needed my computer to get some actual work done. The installer must have told svchost not to allow standby while it's installing and by simply killing it, it never told svchost to allow standby again. Why svchost doesn't realize that when the computer is rebooted is beyond me.

Somehow killing svchost.exe today made this whole install process restart in a way that simply rebooting did not. By gently canceling the install it reset svchost's dont-go-into-standby setting, and voila standby happiness.

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

Maybe that software installation installed a service before you killed it?

svchost.exe is the hosting process for any number of services that are running.

Run msconfig to see what services are being started and see if any look suspect. You can always disable any you think may be the culprit to help troubleshoot.

share|improve this answer
add comment

Have you had a chance to look at the following documentation from Microsoft? Article ID: 907477 (How to troubleshoot hibernation and standby issues in Windows XP)

Also have a look here: Windows XP Standby and Hibernate Problems Solved

share|improve this answer
    
thanks, I took a look at these -- but didn't find anything. –  JohnnyLambada Oct 29 '09 at 17:51
add comment

Sleep problems occur again and again on this forum, so here is a retake for XP of my stock answer. Things to try:

  1. Look in your BIOS for the suspend ACPI options and try to switch modes among "S1 and S3", "S1", "S3" etc.
  2. Turn off Hybrid sleep, see explanation here (for vista, but is the same)
  3. The hibernation file is sometimes disabled by disk cleaning, to restore do in cmd run as administrator "powercfg -h on".

Note: Any of the above manipulation that doesn't help should be undone.

share|improve this answer
    
thanks! Tried it -- didn't help. –  JohnnyLambada Oct 29 '09 at 17:55
    
I've edited-in some more advice. –  harrymc Oct 29 '09 at 20:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.