Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I setup a new server running OmniOS and installed napp-it to configure all my ZFS settings and shares.

I successfully mounted my NFS share on my Mac, but I'm unable to copy existing files/folders on my Mac to the NFS share. I can create new folders and files on the share from my mac, but existing ones can not be moved.

Interestingly enough, I can copy files/folders via the terminal, but not with the Finder.

Is there a setting I'm missing in napp-it to get NFS shares working correctly on my Mac?

share|improve this question
add comment

2 Answers

try rw=@182.168.0.77,root=@182.168.0.77

also look at: - share ACL: everyone@=modify (restrict only on created files and folders, not the share) - nbmand must be set to off - check share settings for permissions (user or group)

share|improve this answer
    
Thanks for the reply. I tried changing the values to what you specified but it's still not allowing me to copy a file via Finder (finder asks me to enter my password to make changes, and then after I enter my password it says the file already exists and if I try to replace it it says "The operation can’t be completed because an item with the name “” already exists." everyone is set to modify, root is set to full. nbmand is turned off. I can access the share and see all the data and even write new files to it on my Mac, I just can't copy files using Finder. –  Kris Anderson Jul 25 '13 at 10:19
add comment
up vote 0 down vote accepted

Through enough trial and error I was able to get my Mac to copy files to my NFS share using Finder.

For those running napp-it and wanting to get things working, open up your ZFS settings and look for some options below all your NFS shares. One of which is aclinherit which defaulted to "restricted". I changed that to "discard" and now my Mac is able to copy existing files via Finder.

I believe the NFS server was trying to retain the Mac permissions, and that was causing all the issues. With the "discard" setting, NFS is ignoring the permissions on my local machine, and instead inheriting the permissions from the folder I'm copying to. Since I'm the only user writing to this share, and my permission settings aren't complex, this should work just fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.