Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an original Microsoft Windows 7 USB key. I would like to mount it under Linux, but all my attempts have failed :

# mount -o ro -t ntfs /dev/sdd1 /mnt/usb/
Failed to read last sector (16439295): Argument invalide
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
   or it was not setup correctly (e.g. by not using mdadm --build ...),
   or a wrong device is tried to be mounted,
   or the partition table is corrupt (partition is smaller than NTFS),
   or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/sdd1': Argument invalide
The device '/dev/sdd1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

I have tried with ntfs and vfat without success. How could I mount it please ?

share|improve this question
2  
What do you mean by original Microsft Windows 7 USB key ? Is it simply that it has been formatted by Windows ? By the way, are you sure it's a NTFS parition ? USB keys are often formatted with FAT32 by Windows. –  Levans Jul 25 '13 at 8:55
1  
What does sudo fdisk -l /dev/sdd say? –  ahilsend Jul 25 '13 at 9:46
    
I mean the usb key is a Microsoft manufactured one. This information may be important as they might have introduced some special features, I don't know. sudo fdisk -l /dev/sdd Disk /dev/sdd : 8019 Mo, 8019509248 bytes, 15663104 sectors Units = sector of 1 × 512 = 512 bytes Secteur size (logic / physic) : 512 bytes / 512 bytes size of I/O (minimal / optimal) : 512 bytes / 512 bytes Disk Id : 0x00000000 –  lalebarde Jul 25 '13 at 11:21
    
But, have you tried mounting the key as a FAT32 partition, or even without specifying the -t ... option to mount ? –  Levans Jul 25 '13 at 11:45
1  
Disk Id : 0x00000000 ? Very interesting. According your fdisk -l output there no any partitions on your disk. That is why you can't mount. Try to reformat it. –  september Jul 25 '13 at 16:13

1 Answer 1

up vote 0 down vote accepted

I finally ordered a reinstallation DVD. By error, they first sent me another USB key, which lead to the same result. Of course, with the DVD, everything is fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.