Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi all I am doing some website development in PHP and I recently moved to a rural area and have hughes net satellite internet. I am using wamp server with apache 2.4.2 to develop locally however I need to get my server online so that I can work with the google API.

I have followed these steps to try to put my wamp server online however it is still inaccessible externally, I get a 504 error connection took to long to respond.

  1. Went to the wamp server tray icon and 'Put Online' and the icon turns green.
  2. Confirmed it is listening on port 80.
  3. Went into my router and forwarded port 80 to my internal IP address.
  4. Disabled the firewall and filtering features inside the router.
  5. Tried to access my server with it's external ip address as obtained from a quick google search, and confirmed inside the modem's configuration page (used my phones cellular connection to try this).

Not working.

Ideas?

share|improve this question
    
It's very possible that incoming connections are filtered by Hughes net. (been there done that) You may need to contact them directly and get them to permit all incoming traffic. –  TheCompWiz Jul 25 '13 at 14:35
    
Have you tried serving it on a different port? –  Flup Jul 25 '13 at 15:30
    
Yes @Flup I tried port 1987 didn't work. I was able to ping the IP address however using an online port scanner shows them as closed. –  slick1537 Jul 25 '13 at 17:30
    
I got it going on a cable connection so I am going to guess the issue is the satellite internet. –  slick1537 Jul 25 '13 at 18:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.