Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using the windows 7 home premium 64 bit OS, the drive gets detected& i see it in the MY COMPUTER area but not in the bios. I even updated my bios through the dell website. I want to use it as a bootable device. Or should i change like from LEGACY to UEFI mode ? step by step guidance would be appreciated. thanks in advance.

share|improve this question
    
What sort of partition are you using currently MBR or UEFI? –  Ramhound Jul 25 '13 at 18:16
add comment

1 Answer

Well it seems as if you reach the limmit with the 4TB drive. I think the limmit of BIOS based clients is 2.1TB or so. I would recommend switching to UEFI as UEFI allows you to boot with disks larger than 2TB. Almost forgot, you need to format the disk GPT otherwise you wont be able to make use of the 4TB. The only problem with that is, that you cannot boot from a GPT converted disk, except with windows 7. According to this article:

GPT disks are self-identifying. All the information needed to interpret the partitioning scheme of a GPT disk is completely contained in structures in specified locations on the physical media.

So the OS needs to know how to read GPT disks, which windows 7 does.

I would recommend that you create two 2TB partitions. One as boot-disk the other for DATA.

Also check here:

Installing Windows Server 2008 on disk larger than 2TB

Installing windows 7 on a 4tb hard drive

Do I need UEFI enabled in BIOS for a 4TB external, non-boot disk?

share|improve this answer
    
check the first comment: social.technet.microsoft.com/Forums/windowsserver/en-US/… –  M.Meintjes Jul 25 '13 at 18:25
    
have you ever tried it before? because windows 8 wont allow you to do so. I tried it myself on this very PC. I converted it to GPT and Windows grayed the option of installing windows on it out. –  M.Meintjes Jul 25 '13 at 18:29
    
I was able to install Windows 8 on a 4TB HDD without a problem. The author's problem is something else considering they don't even see the device and they should. –  Ramhound Jul 25 '13 at 18:35
    
My apology @Ramhound it seems you were right about windows 7. I updated my Answer. But its funny because it didn't work with my setup :S –  M.Meintjes Jul 25 '13 at 18:37
    
That would be something we would have to explore in your own question or the chat. –  Ramhound Jul 25 '13 at 18:42
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.