Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get into my Toshiba laptop's bios so I can boot from USB to install Xubuntu, but the POST is darting by too fast for me to try different keys, and the first thing I see on my screen when booting is the Windows logo. I don't even see Toshiba's logo anymore.

Does anyone know the correct key to access the BIOS on a Toshiba Satellite L755 series? Exact model is L755-S5246.

share|improve this question
1  
I have to issue a downvote because of the lack of research on your part I discovered this thread forums.toshiba.com/t5/Computer-Troubleshooting/… from the following google search google.com/… –  Ramhound Jul 25 '13 at 18:46

2 Answers 2

up vote 0 down vote accepted

After trying all the options on forums and the Toshiba site, I went through all the f keys a couple of times and found f12 worked the second time around. Try ctrl+alt+delete to reset to Toshiba screen quickly when one doesn't work and it begins to load os or go to blank screen. To load ubuntu I had to disable safe boot to change bios to old version, non uefi called csg or something. Boot worked fine for linux after that. Alternatively, if you still have windows 8 installed, go to start menu type bios in search bar, click on change advanced settings(think it was called, the first obvious option anyway) and you can do it through the interface provided.

share|improve this answer

Well, if you need to access BIOS on your Toshiba laptop - Press and hold the f2 button as soon as it is restarted or turned on.

P.S - The reason why you do not see your BIOS screen is because of a quick boot. You should be able to find the option for something like boot speed in the advanced menu within the BIOS and if you change it to normal and save the settings then it should be fine.

Cheers !!

share|improve this answer
    
I was able to get in with F12 shortly after posting the question. And yeah, it was set to quick boot, which is a little odd because I don't remember setting that. Oh well. Now I get to begin my transition into a Linux user! –  Akai Jul 25 '13 at 19:16
    
@Akai Glad that you're in the next step now. By the way the issue that you experienced with regards to quick boot would possibly be due to an automatic BIOS update if you have not changed the setting manually. Please care to mark your question as answered if you consider this issue to be resolved. Thanks. –  Vikash Jul 25 '13 at 19:22
    
so if I have quick boot, then to get into bios, I will first have to get into bios, and turn of quick boot. –  richard Sep 1 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.