Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question seems to have been asked in very similar form in the past, but I was unable to find a relevant answer her or elsewhere.

I am ultimately looking to install a dual boot of x64 Windows 8 and Arch Linux on my machine. According to this Arch Wiki page, x64 Windows 8 booted with UEFI requires a GPT partition scheme for the dual boot to work.

After checking, it was clear the system was using an MBR partition scheme.I used

I suspected the machine was booting using UEFI: when I booted up the Arch install media (I am using usb), I found that the directory /etc/firmware/efi existed.

Since an MBR/UEFI is precisely what the Arch page says what won't work, I tried to re-install Windows, attempting to change the disk to GPT (though I failed): I used gdisk in the arch install media to convert the partition table to GPT and then installed Windows 8, but is seems the installation process replaced the GPT with an MBR--Windows utilities indicated the disk was MBR formatted.

Frustrated, I decided to try to install Arch anyways, in the belief that maybe the machine wasn't actually booting with UEFI. After completing the install, and using GRUB as bootloader, the machine booted to a Windows error screen, with

File: \Windows\system32\winload.exe
Error code: 0xc000000e

in the error.

I am using a Samsung Series 9 laptop for this process, model NP900X4C-A01US.

My machine has a UEFI option in the BIOS' boot menu (and it is enabled), but the menu item writes,

'Enabled' means the system can boot Legacy OS or UEFI OS. 'Disabled' means the system can boot Legacy OS only.

As a result, I thought the system on my machine was possibly using BIOS instead of UEFI to boot, but it seems this hypothesis didn't pan out.

I'd be happy to provide any other information.

share|improve this question
    
You need to boot the Windows Installation disk in UEFI mode. You should be able to specific tell your system to load UEFI media only. –  Ramhound Jul 25 '13 at 22:59
    
How would I go about doing that? –  Arturo Jul 25 '13 at 23:13
    
That depends on what motherboard you have. –  Ramhound Jul 26 '13 at 1:18
add comment

1 Answer 1

You could try downloading a CD-R or USB flash drive version of my rEFInd boot manager. (If your Windows installer is on an optical disc, you'll need to use the USB flash drive version of rEFInd.) Prepare a medium and boot to it, with your Windows installation medium also attached/installed. rEFInd should show you options to boot to the Windows installer. If it doesn't, wait a few seconds and hit the Esc key. The default configuration for rEFInd on UEFI-based PCs is to show only EFI boot options, so you can be sure that you'll boot the Windows installer in EFI mode if you do this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.