Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to use cyber duck to connect to my FTP server. I have been able to upload files just fine until I try to use hotel wifi. I am able to connect to the server, view all the file listings but when I try to drag a file to start an upload I get a 500 I won't open a connection to (some ip) only to (other ip). I think this may have to do with a proxy that the hotel wifi uses. I tried using Hot Spot Shield on my mac but I haven't had any luck.

A quick summary:

  • FTP (Home Wifi) will upload, download, and list directory; everything works perfectly
  • FTP will list files but won't successfully upload or download files
  • A VPN won't fix the problem

I think if I created a VPN to my home network where FTP works I would be able to get everything to work but I can't setup a VPN remotely. Are there any way to check how a proxy is handling requests? Is there a way to check if the FTP port is blocked(even though I can list the directory)?

Cyber Duck Error

Any help is greatly appreciated!

share|improve this question
up vote 2 down vote accepted

You must set the connect mode to "Passive (PASV)" in System Preferences → Network → Advanced... → Proxies → Use Passive FTP Mode (PASV) or in the bookmark in Cyberduck. Or you can update to the latest snapshot build of Cyberduck which will automatically try the alternate connect mode (PORT or PASV) when the first fails.

share|improve this answer
    
I first tried to update the setting in the system preferences and it did not fix the issues I was having. In retrospect, I probably should have restarted Cypberduck to see if the change had an effect. However I updated to the latest Cyperduck version and I am now able to upload my files. Thank you for the help. If you have the time I would be interested to know what exactly the PASV mode does. Thanks again. – anglinb Jul 27 '13 at 0:18

You must log in to answer this question.

protected by bwDraco Apr 11 '15 at 6:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .