Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've spent the past day trying to get GPT to work with my installation/mobo. I have a GA-990FXA-UD3 rev1.0 motherboard, and I'm trying to install ubuntu over two drives, an SSD and a HDD with the following partition scheme:

SSD: (120Gb gpt)
5mb - unpartitioned boot_grub
10Gb - /boot
50Gb - /

HDD: (3Tb, gpt)
25Gb - swap
25Gb - /var
100Gb - /media/Music
1.5Tb - /home
100Gb - /opt
100Gb - /usr/local

However, when I reboot, my BIOS sticks at the "Loading Operating System.." screen. I've tried switching between AHCI and IDE for my drives, but it doesn't seem to help, so I'm left wondering if my mobo can't read GPTs.

share|improve this question
1  
@Marco provide the proof everything I know about MBR and GPT says othwrwise –  Ramhound Jul 26 '13 at 19:29
1  
A basic BIOS just reads the first sector of the disk and transfers control to it; it does nothing with partition tables. Some more advanced BIOSes do try to parse partition tables and often cause problems as a result. The EFI/GPT and BIOS/MBR ties are in Windows. Linux, FreeBSD, and several other OSes can boot fine on BIOS-based computers from GPT disks. I've done this myself on several computers. See my Web page on the subject for more information. –  Rod Smith Jul 27 '13 at 0:25
1  
@Ramhound I set up several systems with GPT partition scheme, using UEFI and BIOS and it mostly works fine, given a not too ancient system. The last one was a Lenovo Thinkpad L412. –  Marco Jul 27 '13 at 3:12
1  
@cbabb GPT partition tables work on UEFI systems, UEFI system in BIOS emulation mode and older BIOS systems without UEFI. Did you try it? If it didn't work, it might be a buggy BIOS (which is actually not uncommon). –  Marco Jul 27 '13 at 3:20
1  
I can't speak for Marco, but I can say with 100% certainty that I have booted from GPT disks on BIOS-based computers. See the Wikipedia entry on the BIOS Boot Partition for evidence. To quote it, "the BIOS Boot partition is a partition on a data storage device that may be used by standard BIOS-based machines in order to boot when the partition table of the device is a GPT label." Note that I'm the author of GPT fdisk and of rEFInd, so I know this subject well. –  Rod Smith Jul 27 '13 at 20:10

2 Answers 2

up vote 1 down vote accepted

According to Gigabyte's website, this board (Rev 1.0) is BIOS; therefore it only supports MBR. Rev 3.0 of this model and onwards is UEFI based with Legacy mode. With your current board, you can not use a GPT disk. If you want to use this setup, you would need to upgrade. Cross flashing in this case is not possible either; even though the products are identical. Rev 1.0 is Award (BIOS) and Rev 3.0 is AMI (UEFI).

GA-990FXA-UD3 (rev. 3.0)

share|improve this answer
    
Thank you, that's what I wanted to know. –  Naddiseo Jul 26 '13 at 3:19
2  
This is incorrect; see my response. –  Rod Smith Jul 27 '13 at 0:26

The Web page linked to in the original post includes the following feature specification:

  • Patented DualBIOS with Hybrid EFI technology for 3TB HDD support

The Hybrid EFI is a very buggy EFI implementation that's built as a layer atop a traditional BIOS. I've got a computer with this setup myself, and the firmware implementation is pretty awful. It is possible to boot it from a GPT disk, in both BIOS mode and in EFI mode (I've done so in both modes), although I've never tried it with a 3TB hard disk, so that may create some additional wrinkles. I'm not sure offhand what's causing your system to fail to boot; it could be any of dozens of problems, such as a missing boot loader, a misconfigured boot loader, or a BIOS bug.

One common requirement on some EFI-based systems booting from GPT disks in BIOS mode is to have an MBR partition marked as active. Since GPT includes a "protective MBR" with a single partition of type 0xEE, setting that partition active sometimes works around boot problems. You'll need to use an MBR-only tool, such as all but the very latest versions of Linux's fdisk, to do this; or you can use a very recent version of parted to set a flag on the disk as a whole. (I don't recall the flag's name, offhand, but it is not the boot flag, which identifies an EFI System Partition (ESP).) OTOH, if you decide to try EFI-mode booting, you should probably not set this flag. If you try the flag first and then move on to EFI-mode booting, remove it before you go on to the EFI-mode booting.

Note that you could also convert your SSD to MBR form using gdisk and leave your 3TB spinning disk as GPT. It's conceivable that this would help your computer work past whatever problems it's got. If you do this, you'll probably have to re-install your (BIOS mode) GRUB. Even Windows has no problems with systems that mix MBR and GPT disks, so long as the boot disk is in the right mode for the firmware.

The other approach is to try an EFI-mode boot. This is possible, but it's awkward on this board. One easy way to try it might be to download the CD-R or USB flash drive version of my rEFInd boot manager and prepare a suitable medium. When you boot from it, rEFInd should show you a set of boot options. If one of these boots into Linux, then you can try a disk-based installation. To do this, you'll need to shrink one of your partitions by ~550MiB and create an EFI System Partition (ESP) in that space. Mount that partition at /boot/efi and install the Debian package of rEFInd. Unfortunately, one of the bugs of the Hybrid EFI is that it tends to forget its boot entries, so you might then want to type sudo mvrefind.sh /boot/efi/EFI/refind /boot/efi/EFI/BOOT. This will rename rEFInd to boot using the EFI fallback filename, which will probably be more reliable on this board.

One more point: The downloads page for your board includes a "beta BIOS," which is probably a more reliable non-BIOS-based EFI. I can't promise it will work any better than whatever you've got now, but it might. (OTOH, if you're already running this "beta BIOS," it could be that returning to an earlier Hybrid EFI version would help fix your problem.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.