Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a file that needs to be executable in Linux, which I'd do by using chmod +x when using Linux.

My problem is: this file is compiled in Windows, and it's a pain to have to open my Ubuntu VM to just chmod it.

Is there a tool, or a method in Windows to allow me to add the +x permission to the file, so it is executable upon receipt to a Linux machine?

I've tried searching SU and Google, but I'm only seeing irrelevant results about how chmod doesn't exist on Windows, and to use file permissions instead - but this isn't what I'm looking for.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The key phrase in your question is "executable upon receipt", and the answer depends on how it's being received. If you send a tarball, you can have some executable files in it. A single file could be mailed in uuencode format with begin 755 filename in the header. If you provide more details on what tools you have available on the sending side, we might be able to find a way to make it work.

share|improve this answer
    
I thought of using a tar archive, but my problem is getting it to be +x in the first place. Basically, I do all of my development on a Windows machine. It's a project using Adobe AIR, and in that is a requirement to use the NativeProcess class. In doing so, an exe is launched on Windows, and the binary on Linux. It's that binary that needs to be +x. –  Danny Beckett Jul 26 '13 at 23:28
    
Actually, it looks like an untar package is available for AIR. I could put the executable in a tar archive, then untar it on installation. –  Danny Beckett Jul 26 '13 at 23:30

chmod +x sets attribute in the filesystem and is not assiciated with the file itself. So, there is no way to do that you want.

share|improve this answer
    
Damn, I just tried to chmod +x a file on Ubuntu, then email it to Windows, and email it back to Ubuntu; it dropped the +x permission. Looks like you're right unfortunately! –  Danny Beckett Jul 26 '13 at 3:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.