Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had been using QEMU KVM for long time and have few VMs.

Recently I installed XEN Hypervisor following this instructions but decided to apt-get remove xen-hypervisor-4.2-amd64

Problem is that now, I can't use qemu-kmv anymore cause I get the following error when I try to start machines from virt-manager:

Error starting domain: unsupported configuration: Domain requires KVM, but it is not available. Check that virtualization is enabled in the host BIOS, and host configuration is setup to load the kvm modules.

Traceback (most recent call last): File "/usr/share/virt-manager/virtManager/asyncjob.py", line 96, in cb_wrapper callback(asyncjob, *args, **kwargs) File "/usr/share/virt-manager/virtManager/asyncjob.py", line 117, in tmpcb callback(*args, **kwargs) File "/usr/share/virt-manager/virtManager/domain.py", line 1092, in startup self._backend.create() File "/usr/lib/python2.7/dist-packages/libvirt.py", line 681, in create if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self) libvirtError: unsupported configuration: Domain requires KVM, but it is not available. Check that virtualization is enabled in the host BIOS, and host configuration is setup to load the kvm modules.

I have both qemu-kvm and libvirt-bin running:

# service qemu-kvm status
qemu-kvm start/running
# service libvirt-bin status
libvirt-bin start/running, process 10646

If you need more info please ask.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

check if your kvm kernel module is still loaded, and if not load it.

lsmod | grep kvm

if you do not find it, do modprobe -v kvm (or maybe kvm-intel)

share|improve this answer
    
You are right, it wasn't Thanks a lot, I'll try again after restart –  mirkobrankovic Jul 26 '13 at 12:49
    
aleluja, it works after reboot, i did sudo update-grub in meanwhile, don't know if it was relevant. Thanks again :) –  mirkobrankovic Jul 26 '13 at 12:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.