Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi I bought a brand new Asus Q550L notebook from Bestbuy the other day and I removed Windows 8 from it and replaced it with Ubuntu. Now the battery won't charge. It is sitting at 45% capacity, if I unplug from the mains it will use the battery, it also claims to be charging, but it's been plugged in for over 24 hours now and the charge hasn't increased from 45%.

Is it just a faulty battery? Could the fault be with Ubuntu? Could it be a problem with a BIOS setting? (I was fiddling with BIOS to get Ubuntu installed, it uses UEFI).

I would appreciate any suggestions or advice. Thanks.

More details:

I don't believe that the fault is with Ubuntu; if I shut down the laptop and leave it plugged in for an hour or so and then turn it on again then it still shows a capacity of 45%. Also if I press F2 to get in to the BIOS menu on start up it doesn't appear to charge then either.

I don't know if it ever charged under Windows 8. I don't know if it came with a full battery or not. Yesterday I tried to test this by reinstalling Windows from the recovery disk and system image I'd made prior to installing Ubuntu, but it didn't work. It repartitioned the drive and replaced all of the files but failed at the last minute with a warning about too many indistinguishable items, or something like that. After that it would not boot at all but went to a 'grub recovery' prompt; so I reinstalled Ubuntu. This is probably a different question entirely but if the battery is faulty I'll have to find out how to reinstall Windows in order to return the laptop to the store.

UPDATE: I spent some time trying to re-install windows, and failed. But while I was doing that the battery started to work again! After exhausting all possibilities at re-installing windows I gave up and re-installed Ubuntu. Yesterday I used Ubuntu all day with the laptop plugged in, the battery remained fully charged. Last night I used the laptop without the battery for a few hours, and drained it to around 60%. This morning I turned on my laptop and the battery wasn't recognised. I shut down my laptop and tried to turn it back on without the power adapter; it wouldn't turn on, but did do something so it was getting some small amount of power from somewhere. Then I plugged it back in and turned it on, and I'm back to the original situation regarding the battery not charging.

So my two possibilities are: either there is a loose connection, and it's just a coincidence that when it fails it has been failing under Ubuntu; or Ubuntu's battery driver simply does not know how to charge the battery.

Either way I think I will have to return the laptop to the store and hope that they take pity on me and don't make a deal about the Ubuntu thing.

share|improve this question
1  
Some laptops have a keyboard function to disable battery charging. The symbol would look like a battery that is empty. Do you have one of these functions? –  Jason Bristol Jul 26 '13 at 13:56
    
@JasonBristol I don't see one, the laptop manual lists all of the function keys and it doesn't mention one for that. –  EddyThe B Jul 26 '13 at 14:01
    
I am not finding anything on an Asus Q550L notebook, are you sure that is the correct model? You can find model details on the notebook itself –  Jason Bristol Jul 26 '13 at 14:12
1  
Hmm, try what @Pretzel suggested, if that doesn't work try to update the BIOS, like you said this could be a new model with some bugs asus.com/supportonly/Q550LF/#support_Download_8 –  Jason Bristol Jul 26 '13 at 14:26
1  
Can also try a battery calibration test through your BIOS –  Pretzel Jul 26 '13 at 14:27

3 Answers 3

If you were to turn the computer off with the power plugged in, it should charge no problem.

But as far as while you're on ubuntu, try using the upower command/utility to see if you can get the battery to charge.

Also, to double check, try installing another flavor of Linux to see if you run into the same issue.

share|improve this answer
    
Thanks. I don't think it charges when turned off. I think I tried that yesterday, I'm trying it again now to check. Could you tell me how to use upower please? I typed it in to the unity dash and it opened the normal power settings window which I've used before with no luck. Is that it or are their any command line tools. I'll try another linux in a while if I have no luck with anything else. –  EddyThe B Jul 26 '13 at 14:38
    
It should, it's just circuitry at that point. If that's the case, there may be an issue with the battery. –  Pretzel Jul 26 '13 at 14:39
    
Yeah that's what I suspected but I was hoping otherwise. I'll keep trying other options for a while just in case. –  EddyThe B Jul 26 '13 at 14:44

Long story short, installing Ubuntu broke the battery connection. I imagine this has something to do with the firmware changes that manufacturers have had to make for windows 8.

The good news is that when I returned the laptop they didn't notice that I'd tried installing Ubuntu and gave me a refund.

share|improve this answer

I had a similar issue with my N550JV. Oddly enough, disconnecting and reconnecting battery worked for me as well as a BIOS update. You might as well give it a try.

share|improve this answer

protected by Community Jan 10 at 20:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.