Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Windows 8 I don't have the option on a PC I am dealing with to auto login.

In netplwiz I don't have the checkbox, as screenshotted:

enter image description here

Any suggestions?

share|improve this question
2  
Please fix your screenshot –  Pretzel Jul 26 '13 at 13:55

3 Answers 3

Windows 8 is fairly smart, if you do not have the option - then you are most likely on a domain (i.e. a work computer that has policies set for computers on the domain by a central authority trying to encourage security).

Otherwise you are in the right spot, and since the image does not show the necessary checkbox - my bet is you are on a domain.

Take a look at Microsoft's page on that.

An untested workaround

I am not about to test this on my work domain nor would I suggest this, but for the intel piece, do the following as an admin.

  1. Ctrl+R and type regedit
  2. Navigate (on the left) to HKLM\Software\Microsoft\Windows NT\CurrentVersion\winlogon Set the value for AutoAdminLogon = 1 (1 = auto, 0 = off)
  3. Create a string value called DefaultPassword, in the value field enter your password.
  4. Look for/create a value for DefaultUserName (type: REG_SZ), make that the user you want logged in by default.
  5. If you are on a domain, you may need to add a string for DefaultDomainName with the value of the domain you are on.

Again, this is untested. I take no responsibility for you breaking your computer messing around in the registry or angering an IT manager for having an auto-logon setup.

I would discourage it since you really shouldn't need to logout and in that often and it isn't too hard to type out a password for those occasions. That being said, if you try it and it does/doesn't work - please report back for future peoples.

share|improve this answer
    
Well in this case the domain is my own domain used for the microsoft login nonsense. Why should this prevent it? –  Marcus Hughes Jul 26 '13 at 14:04
    
@MarcusHughes - Updated. Looks like STTR also has the fast way of adding keys for you. –  nerdwaller Jul 26 '13 at 14:20
    
No luck, neither (same things) worked –  Marcus Hughes Jul 26 '13 at 14:37
    
@MarcusHughes - This is the right answer to your question. You asked why the check-box was missing, and the reason is because you've joined a domain. If your question is actually "How do I enable auto-logon when the box is missing", then that's a different question, one which may have answers here (amongst other places): Does Windows 7 allow auto-login with a stored password, like TweakUI did? –  Ƭᴇcʜιᴇ007 Jul 26 '13 at 15:37
    
It's not the correct answer as I am certain I am not on a domain –  Marcus Hughes Jul 26 '13 at 16:13

command line:

REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v AutoAdminLogon /t REG_SZ /d 1
REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultUserName /t REG_SZ /d  %USERNAME%
REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultPassword /t REG_SZ /d <Your password>

Domain, if need:

REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultDomainName /t REG_SZ /d %USERDNSDOMAIN%
share|improve this answer
    
This did not have any effect –  Marcus Hughes Jul 26 '13 at 14:39
    
@MarcusHughes REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitc‌​h" /v Enabled /t REG_DWORD /d 1 /f –  STTR Jul 26 '13 at 17:47

I always use AutoLogon from Sysinternals.

With this way that data are encrypted.

share|improve this answer
    
I also tried this, no luck –  Marcus Hughes Jul 26 '13 at 18:27
    
You must run it with admin rights: windows.microsoft.com/en-US/windows7/… –  magicandre1981 Jul 27 '13 at 5:33
    
No, this didn't work. I just retested –  Marcus Hughes Jul 27 '13 at 12:10
    
I use this tool for years and it works. Do you use a local or MS account? –  magicandre1981 Jul 27 '13 at 18:36
    
It was a Microsoft account, I tried converting it yesterday to see if it would work but still no luck. I understand it may work for you but it doesn't here and that's why I am asking for assistance?... –  Marcus Hughes Jul 27 '13 at 23:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.