Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

By default Ubuntu doesn't mount internal NTFS hard drives automatically. A fstab solution not working properly, because of conflicts with the "intelligent" mount system. If I add my hd in fstab and reboot - it will be mounted. But if I go to nautilus, open places panel and click eject button (unmount) and than click on hd again to mount it, I will get an error.

In 9.04 to solve this problem you need to modify hal rules in /etc/hal/... preferences.fdi in my case I modified it for only one drive.

<device>
−
<match key="storage.hotpluggable" bool="false">
−
<match key="storage.removable" bool="false">
<merge key="storage.automount_enabled_hint"  type="bool">false</merge>
−
<match key="storage.model" string="ST3250310NS">
<merge key="storage.automount_enabled_hint" type="bool">true</merge>
</match>
</match>
</match>
</device>

But this is not working in 9.10 - devs removed this function from hal to devkit-disk or udev? I don't know. Could you please tell me where automount rules are stored in 9.10? And how to create new rules, and what program controls automount in 9.10?

share|improve this question
up vote 4 down vote accepted

I found solution finally. Just add

gnome-mount -p Data(change it to your volume label)

to gnome startup applications. Now drive will be mounted at startup and you will be able to mount/unmount it without any errors.

share|improve this answer

You could do this:

sudo aptitude update
sudo aptitude install ntfs-config

Open the program from System > Administration. Choose the drives that you want to be automounted. Click Apply. Make sure that "Enable Write Support for Internal Drives" and click OK.

Worked for me :)

share|improve this answer
    
This will add entry to fstab which is not working good. This is static rule, i am looking for hal like solution which worked in 9.04. You dont need to hack fstab for automount usb drives, same logic should work for hard drives i believe. – easyrider Oct 29 '09 at 12:13
    
Well all I know is it worked fine for me in 9.10. – thegreyspot Oct 29 '09 at 12:17
    
This solution will work in 10.04 too. Let me add a more detailed tutorial: hackourlives.com/… – David A. G. Aug 2 '10 at 8:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .