Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently re-installed Windows 7 Ultimate on my machine, before doing a complete Windows Update which automatically installed many drivers for the hardware components on board.

Then I began some OpenGL software development projects, and I noticed that every time I run the OpenGL program, everything else on Windows runs very very slowly. Windows Explorer, for example, needs 5 seconds to create a new window. As soon as I exit the OpenGL program, everything runs fine again. During the OpenGL session, the CPU and RAM resources are not exhausted (CPU at about 20%).

So I suspected that I got an old or wrong graphics card driver. The reseller where I bought the machine just tells me that the graphics card I got installed is an ATI Radeon HD 4800 Series, this is also the device that's listed in the Device Manager, and Device Manager tells me that the driver is up to date.

I then downloaded and installed Catalyst Control Center from ATI, which apparently did some driver updates. I also went through the settings of CCC, switching everything that was there to 'Optimal Performance'. No noticeable effects. CCC tells me that I have an ATI Radeon HD 4800 Series chipset with device ID 9442 and GPU memory size 4351 MB.

Today I noticed that the new Google Maps is telling me "You are currently running in Lite mode and 3D Earth view is not available." According to their help and various sources on the internet, this should not happen on the latest Chrome/Win7.

How can I find out whether I have the latest driver for my graphics card? How can I at least find out the exact model of the card?

Here's my configuration:

  • 8 GB RAM ('normal CPU RAM')
  • Win7 x64 Ultimate
  • Chrome 28.0.1500.72
  • Catalyst Control Center 2012.1116.1515.27190
share|improve this question

1 Answer 1

Ugh. The culprit was LogMeIn Mirror Driver:

enter image description here

As soon as that one was disabled and the PC was restarted, everything runs like a charm.

share|improve this answer
    
BTW, you might want to mark this as answered. Rather interesting find, though! –  happy_soil Jul 27 '13 at 16:06
    
You can accept your own answer tomorrow :) –  cheeesus Jul 28 '13 at 8:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.