Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am currently trying to set up a Raspberry-Pi as a very light-weight/simple monitoring solution. All it has to do is open up a web-page on boot.

Opening the web-page was easy enough. I simply put a desktop file into ~/.config/autostart with a command like:

chromium-browser --kiosk http://192.168.1.23/monitor.html

So far so good. There are two problems however:

  1. I see a toolbar stating "This page is in German. Would you like to translate it?
  2. When I unplug the R-Pi and re-plug it I get the yellow "restore session" toolbar.

I cannot figure out a way to fix this. I tried with --temp-session hoping the "restore session" would go away. Unfortunately it did not :(

I also tried with --app which did not change a thing.

Any idea how to fix that? Note that I am not fixed on chromium. It just happens to be the one browser I found which makes it easy to launch in fullscreen with a URL in once simple command.

share|improve this question

1 Answer 1

up vote 5 down vote accepted

You should be able to add the two flags --disable-translate and --incognito

chromium-browser --disable-translate --kiosk --incognito http://192.168.1.23/monitor.html

Incognito mode is a funny way to make Chromium not worry about the last session when it restores from a crash.

References: Disable Google Chrome session restore functionality

Chrome command line switches from a conversation on Stack Overflow

share|improve this answer
1  
Interesting. --disable-translate was not listed in --help :) –  exhuma Jul 27 '13 at 18:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.