Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It is killing me for the week. Since Monday, It fails every single time when I try to use pacman -Syu to update my system and gives error messages on the picture. It trys to connect via ipv6. I ping the ips, no host found. Then I switch to wget, it connects using ipv4 addresses. But fails too.

I tried to ping the ip addresses and "archlinux.igor.onlinedirect.bg", it workded. I tried to view the files via web browser, succeeded and I could even download the files. But when I try to run "pacman -Syu", with wget, curl or not, it gives "download library error" every time.

What did I do wrong or what have I been missing? Hope you guys can help.\

It occurred to me it might be the problem of the network. I copied the vdis(sorry I forgot to mention these are virtual os) files home and run "pacman -Syu" it worked. Then I copied the file to office, I still got the same "can't resolve server" error. Do I need to post some files?

share|improve this question

migrated from stackoverflow.com Jul 27 '13 at 19:38

This question came from our site for professional and enthusiast programmers.

    
I came to this question because the pacman tag made me think it was about the game. I feel stupid now. +1 because I feel guilty. –  Marc Claesen Jul 26 '13 at 10:11
1  
This doesn't sound like a programming question. Perhaps you would be better off asking this on Super User? –  Lasse V. Karlsen Jul 26 '13 at 10:12
    
Always failed when I played it as well, could never get the hang of that game. –  Tony Hopkinson Jul 26 '13 at 10:13
    
This question is really better suited for Super User! –  Jonatan Jul 26 '13 at 10:19
    
Thanks for the information. I'll try SuperUser. Do I need to delete this one? –  user1960581 Jul 26 '13 at 10:24
add comment

2 Answers 2

This sounds like it could be an issue with your firewall. does ip6tables.rules exist? You may need to make sure your kernel supports ip6tables and conntrack. You can check your firewall with :

systemctl status ip6tables

share|improve this answer
    
I have disable ip6tables for the very beginning. I'm afraid that is not the problem. –  user1960581 Jul 30 '13 at 2:34
add comment

It seems like there is some error with your mirror. Try changing the list of mirrors in /etc/pacman.d/mirrorlist to another mirror.

EDIT: Yeah, sorry, I misread the question. It seems like pacman is trying to connect through a proxy. Check your pacman configurations to see if your proxy settings are correct, and that your terminal doesn't have incorrect *_proxy (http_proxy, https_proxy, etc.) environment variables set.

share|improve this answer
    
No, I don't have a proxy and have no proxy options in the pacman.conf file. Thanks all the same. –  user1960581 Jul 30 '13 at 2:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.