Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using windows 7 64 bit and installed the latest virtualbox (4.2.16). I then create a host-only adapter by going to File > Preferences > Network > + . Then I go and edit it to make sure everything is correct. The ipv4 address set is 192.168.145.1 (I know by default some people get 192.168.56.1 but since virtualbox gave me that I'm not changing anything) and the subnet is 255.255.255.0. DHCP is also disabled and I believe these configuration is enough to use host-only networking with static ip for host and guests. Then I create a new VM and added the host-only adapter as its main network interface. Go through the setup of windows server 2008 r2 sp1 and finally when everything is done, I configure the ipv4 address of the server to be 192.168.145.2, subnet 255.255.255.0, and empty DNS.

Finally when its time to test if both host and guest can communicate with each other, I 'cmd > ipconfig /all' both host and verified that the ip configuration I put earlier is just like what I wanted. I ping the HOST FROM GUEST, and it worked. But when I ping the GUEST FROM HOST it doesn't work and always request timed out. Any idea what did I miss? I believe this is as simple as it get as I don't want the guest to have internet access.

Some extra info:

  1. Both host and guest are showing 'Unidentified Network, Public Network' in the Network and Sharing Center. I chose for it to be that way.
  2. The host is also connected to the internet via a physical wireless adapter.
share|improve this question

migrated from serverfault.com Jul 28 '13 at 11:42

This question came from our site for professional system and network administrators.

add comment

1 Answer 1

up vote 0 down vote accepted

Ok so I turn off the windows firewall on the guest and finally I can ping it from the host. I researched more and found that windows server 2008 firewall by default disable outside machine from pinging it. You also need to manually open a port for your application most of the time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.