Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to change the command line of gnome-terminal to include geometry of both size and location. I already know how to set size using the configuration editor, but not location.

There must be some file I can edit to add --geometry 80x55-500+0 to get the terminal where I want it. When I press Ctrl+Alt+T what actually happens? How do I use it to change the window location?

share|improve this question
I've edited your question because it felt like it's an XY problem. Feel free to rollback the changes (rollback button here) if you feel like your real intentions are lost. – gronostaj Jul 28 '13 at 14:33
Agreed - I'm still curious about "what happens", but getting to happen is the important thing. – Mike Rosing Jul 28 '13 at 15:25
up vote 2 down vote accepted
  1. Click your username in the top right of the screen and select System Settings.
  2. Under Hardware click Keyboard.
  3. Switch to the Shortcuts tab.
  4. Click custom shortcuts.

enter image description here

share|improve this answer
5. Hit the + and type in the name (as shown) and command (I used gnome-terminal --geometry 80x55-500+0) – Mike Rosing Jul 28 '13 at 15:27
6. Hit apply and then click on the new "Launch Terminal" where it says "disabled" and hold Ctrl-Alt-T. Say yes to reassign from standard launch. – Mike Rosing Jul 28 '13 at 15:32
That works, and now I'd like to know why it works :-) Thanks! – Mike Rosing Jul 28 '13 at 15:33
Man! you are a savior. I tried to edit preferences of the terminal window but failed miserably. the terminal opens up in an infinite loop. Same occurs when I try to execute the gnome-terminal command by running a shell script from bashrc file . Strange it was so easy but yes , I am curious to know why did it work in this case. Thanks. – 0decimal0 Jul 19 '15 at 13:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.