Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The official help just says that there is spell checking context menu for edit fields. Yes I see "spell checking" on context menu.

But I see no red underlines to mark misspelled words as I write words. When I click "spell checking" on context menu, it apparently does nothing, I'm not sure what it's supposed to do: toggle spell checking mode (red underlines) on and off, or popup something like a find-and-replace dialog box?

Update:

It seems I was confused because my installation of Opera was broken with spell-checking feature (Opera 10.01 (current stable version) on Ubuntu 8.10, installed with the default package from the Opera homepage). Right-clicking on a textarea didn't show "Dictionaries" item, for example.

But after I installed Opera 10.10 beta (again with the default beta package from the Opera homepage), it works and makes sense. Red underlines appear on misspells and there is "Dictionaries" item.

share|improve this question
1  
If that was the solution, post it as an answer and accept it - then it'll be easier for others to see the solution. –  ChrisF Oct 30 '09 at 9:11

3 Answers 3

up vote 2 down vote accepted

Quick answer to what it is supposed to do. The spell checker is underlining misspelled words in red, a bit like you can see on word processors.

It won't popup a "check mistakes and replace them" dialog. However, when you will have a misspelled word, right clicking on it will show propositions of correctly spelled words in the context menu.

If you have several dictionaries, you will be able to switch which dictionary is active, at the bottom of this context menu.

Edit: More details on adding dictionaries can be found on Opera's site.

share|improve this answer

I use Opera 10 and the spell checker worked for me right out of the box. It works in text areas (multiple lines), not in textboxes (single line). Right now, the word "textboxes" is underlined in red.

By default, the US English dictionary is installed. You will have to add it for another language by right-clicking in a text area and choosing Dictionaries -> Add/Remove Dictionaries

share|improve this answer
    
+1 - didn't think of that! –  ChrisF Oct 29 '09 at 13:19

Obvious question - have you selected "Check Spelling" on the context menu? It's an option rather than an action and should have a tick (check mark) next to it if spell checking is enabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.