Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Finder used to show a warning dialog when I tried to open many files at once. Something like "Opening 100 files simultaneously may slow down the system. Are you sure you want to do this?"

I disabled this dialog, and now I want it back. Unfortunately I can't remember what I did to get rid of it.

share|improve this question
    
Did you enter something into terminal like: defaults write com.apple.finder (OpeningTooManyWarning) -bool False (Was true)? – Carl B Aug 8 '13 at 6:59
    
@CarlB I guess so, but I can't find out which one it was – user123444555621 Aug 8 '13 at 13:30

I believe this has something to do with the launchctl limit

First run;

launchctl limit

Check to see what your output is; it should look kind of like this;

   
    cpu         unlimited      unlimited      
    filesize    unlimited      unlimited      
    data        unlimited      unlimited      
    stack       8388608        67104768       
    core        0              unlimited      
    rss         unlimited      unlimited      
    memlock     unlimited      unlimited      
    maxproc     709            1064           
    maxfiles    256            unlimited 

If you notice your maxfiles is set >256 then;

sudo vi /etc/launchctl.conf

Edit the file accordingly, and soft maxfile vaule back to 256.

I've also attached a link to all the default commands in case this isn't a fix for your issue. https://github.com/mathiasbynens/dotfiles/blob/master/.osx

share|improve this answer

To check limits on your system run:

launchctl limit

To change max number of open files run:

launchctl limit maxfiles X unlimited

where X is the maximum no: of files.

To change the setting permanently add to the file: '/etc/launchd.conf' following line:

limit maxfiles X unlimited

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .