Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Owncloud 5.0.9 is installed on my raspberry pi and is working flawlessly. But since my raspberry pi hasn't much space, I wanted to move the data directory on an external drive.

I have a 1,5GB external drive formatted in NTFS mounted on /home/pi/media and the new data directory is /home/pi/media/owncloud/data/

The /etc/fstab/ looks like this:

UUID=xxxxxxxxx   /home/pi/media    ntfs-3g     defaults      0       0

It doesn't work if I set the permissions on the ntfs drive with

sudo chown -R www-data:www-data /home/pi/media/owncloud/data

The browser is giving this error if I go to xxx.xxx.xxx.xxx/owncloud/:

Data directory (/home/pi/media/owncloud/data) is readable for other users
Please change the permissions to 0770 so that the directory cannot be listed by other users.

How do I set the permissions right? Also MiniDLNA is configured to use this drive, so it should not interrupt each other.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Got it myself!

By default you are not able to set permissions on NTFS formatted drives, but with NTFS-3G you can. Just enable it on mount.

  1. Add permissions to the options in /etc/fstab/. It should look like this:
UUID=xxxxxxxxx   /home/pi/media    ntfs-3g     defaults,permissions      0       0
  1. Reboot your Raspberry Pi so that the drive get mounted with permissions.
sudo shutdown -r now
  1. Now you are able to set permissions. For owncloud like this:
sudo chown -R www-data:www-data /home/pi/media/owncloud/data
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.