Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I occasionally get this problem where for some reason small, dotted gray boxes appear around my desktop icons. It always goes away after I restart, but I'm just curious what it is. I don't know of anything in particular I do to cause it, but it only outlines icons I click, and it only does it to one icon at a time. The picture below is the box on the recycle bin. IF I click a different icon it'll happen to that one instead. I'm using windows 7.

enter image description here

Thank you.

share|improve this question
Thanks for the answer MrSeed. Unfortunately, I already tried all the options listed (tab, icon size, refresh etc.) and the ones I didn't try all require a restart, which fixes it anyway. Nonetheless it's interesting to know that there isn't a cut-and-dry cause. The only solution I'm really interested in is one that can be done without restarting. – Max Jul 29 '13 at 11:13
well as stated in my answer below you can remove the dotted lines around the desktop icons my clicking once on the taskbar, however it is only temporarily until you click on the icon again. you can also try and hit the Tab key until its gone. – Meintjes Jul 29 '13 at 12:13
Have you tried playing around with the visual settings in Windows? Right-click My Computer, click Advance System Settings from the left pane, click Settings under Performance. You should see a window that has full of tick boxes for adjusting various visual effects. – happy_soil Jul 29 '13 at 12:37

Well this is a very popular question out there on the internet. Some say it has something to do with the keyboard others say its a bug. Actually it is so that you can see what icon you selected on your desktop. You can temporary remove this by deleting your icon cache.

The icon cache will be rebuild automatically so as mentioned this is not a permanent solution.

also check this: Remove Dotted Border Around Icons on Windows Desktop

Or you can simply click on your taskbar to get rid of it. What also seem to work is hitting the Tab key until its gone.

share|improve this answer
  1. In task manager processes, kill explorer.exe
  2. While still in task manager go to File -> Run and enter explorer.exe

Note: If you goof and close task manager just hit ctrl+alt+del and pick task manager.

share|improve this answer
Hello, and welcome to Super User! What do you mean with "3 button salute"? ctrl-alt-del? – Valmiky Arquissandas Aug 22 '14 at 2:04
Thanks for the welcome! and, yes, you got it right. I did IT contract for the Air Force and that was the "tech term" for it. It stuck after and I got to quit using it I think. – phque Aug 24 '14 at 5:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.