Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have finally got rid of win 7 and installed Fedora 19 on my laptop.

Everything works except for the usb-networking...

Details follow:

#uname -r
3.9.9-302.fc19.x86_64

#NetworkManager Tool

State: connected (global)

Device: enp0s29u1u3 [Wired connection 1]
Type: Wired
Driver: rndis_host
State: connected
Default: yes
HW Address: 42:8D:4D:4B:40:5D

Capabilities:
Carrier Detect: yes

Wired Properties
Carrier: on

IPv4 Settings:
Address: 192.168.42.132
Prefix: 24 (255.255.255.0)
Gateway: 192.168.42.129
DNS: 192.168.42.129

#Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.42.129 0.0.0.0 UG 0 0 0 enp0s29u1u3
172.16.151.0 * 255.255.255.0 U 0 0 0 vmnet1
192.168.42.0 * 255.255.255.0 U 1 0 0 enp0s29u1u3
192.168.105.0 * 255.255.255.0 U 0 0 0 vmnet8

# cat /etc/resolv.conf
#Generated by NetworkManager
nameserver 192.168.42.129

I can ping any site on the internet but cannot browse it - have tried all curl, lynx, firefox - without success

also I have tried to flush the iptables and manually set policy for INPUT, FORWARD and OUTPUT to ACCEPT.

I have completely run out of ideas...

pls help, will be really glad

MORE information: the connection is provided by my Motorola Xoom (MZ601) tablet via USB tethering.

I have just found out that HTTPS works but HTTP still does not.

I set the tablet's USB to 'Debugging' mode and !!!VOILA!!! now both HTTP and HTTPS work.

I would love to know the reason... nonetheless the problem is solved (strange - in windows it worked even in normal mode - without usb debugging...)

share|improve this question

migrated from serverfault.com Jul 29 '13 at 22:41

This question came from our site for professional system and network administrators.

    
Please read what a site is for before posting. –  Chopper3 Jul 29 '13 at 19:44
    
yes, I did read that. Is there a reason to believe that profi-server admins would not be familiar with networking? –  user2433984 Jul 29 '13 at 20:43
    
unix/linux stackexchange site is better for this question. –  Dan Pritts Jul 29 '13 at 21:35
    
Just because professional system administrators come here does not mean that your question is on topic here because we might be interested. –  longneck Jul 29 '13 at 22:29
add comment

1 Answer

as already stated above - the problem was obviously the communication between my Android device (Motorola Xoom MZ601) and Fedora 19. For some reason Fedora 19 requires the device to have the USB set to the USB debugging mode prior to attempting the USB tether.

hope this helps other users, too

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.