Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Okay, so I installed l-ubuntu on virtual box (which is installed on windows 7-64 bit) and then on vmware player successfully to learn some bash programming. Then, I connected my computer to the internet with an ethernet cable. When I disconnect the ethernet cable, I lose my wifi connection on the guest OS, ie windows 7. But, I can connect using an ethernet cable. Now I have to sit near my wireless gateway :P

I noticed that this problem was solved when i uninstalled virtualbox. But, it happened with vmware player too. I tried using windows "troubleshooting", but it does not work.

How do I get out of this mess ? I need virtualized lubuntu badly and with a working wifi connection.

share|improve this question

2 Answers 2

I just fixed it. It was disabled, probably by windows host, in the "change adapter settings" menu of "network settings" in windows. Simple fix.

Steps -

Start > Control panel > Network and Internet > Network and sharing center >......

Or you could do all of the above steps in one step by clicking on the internet/wifi icon on your taskbar and then choosing "open network and sharing center".

From here, go to change adapter settings. Your wireless connection should be visible here. It will be disabled (red cross next to its icon). Right click it > enable.

share|improve this answer
    
Can you expand a bit, for people who may not be as tech savvy as yourself? –  Canadian Luke Jul 30 '13 at 19:39
    
@CanadianLuke - lol. I am not so tech savvy. I was just plain lucky. Updating the answer now. –  bashboy Jul 30 '13 at 19:53
    
Looks much better! –  Canadian Luke Jul 30 '13 at 20:03

Bridged networking will not work over Wifi. It will work over physical LAN. This is a limitation of one MAC per client in standard wifi client mode.

NAT will work over both.

Its my guess that you are using bridged networking, because it would work in exactly the manner you have described.

share|improve this answer
    
ok, but how do I fix it ? It was working before. –  bashboy Jul 30 '13 at 18:55
    
configure all of your guests to use NAT networking. Avoid bridged. –  JonnyRo Jul 30 '13 at 18:58
    
btw, i just fixed it. It was disabled, probably by windows host, in the connection adapter settings. simple fix. –  bashboy Jul 30 '13 at 19:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.