Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My browsers are not displaying the http://superuser.com website as they should.

When I go here in IE, it renders incorrectly (my guess is it renders without CSS); then IE displays a message

Internet Explorer blocked this website from displaying content with security certificate errors

I click on "Show content" and everything looks OK. Web is colored and rendered as expected. In Firefox I have the same issue but can't find any option/settings to correct it. I check many other web sites but everything looks OK.

I already:

Reset Firefox preferences "https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems"

And Add Exception "http://www.andrewlucking.com/archives/2007/10/secure-connection-failed/" for "http://superuser.com/"

I have: Win7 sp1 64-bit, Firefox 22.0, IE 9

share|improve this question
    
Do you get an error message when browsing with Firefox? Does it occur only with SuperUser or with any of stackexchange sites? – Dave Jul 30 '13 at 12:23
    
No error message.It is only this web, stackexchange.com is OK; askubuntu.com NOT OK; – slim Jul 30 '13 at 12:39
    
So, you mean both SuperUser.com and askubunut.com are BOTH incorrectly rendered? – Dave Jul 30 '13 at 12:54
    
Yes both. Even stackexchange.com/sites# have problem to show images in sites "boxes". – slim Jul 30 '13 at 13:02

This issue can be caused by browser security settings, anti virus or firewall. It may also be caused by an incorrect time/ date on your computer.

However, since your issue is quite localised (ie, only affecting a few sites) I would think it's a problem with FireFox only.

I would open FireFox, click on Tools -> Options and ensure the privacy and security settings are ok.

I also suggest opening Firefox in safe mode in case it's a plugin issue. At the top of Firefox click the orange Firefox button -> Help menu and select Restart with Add-ons Disabled.

share|improve this answer
    
privacy and security settings are OK = default – slim Jul 31 '13 at 5:47
    
After "Reset Firefox preferences", Add-ons was gone – slim Jul 31 '13 at 8:56

SOLVED by myself - accidentally

How I found solution ? I just try Opera. Opera behaved same as Firefox. But my curiosity told me to show picture on page http://stackexchange.com/sites which was not showed. I make right click and choose "Open image in new tab" I've got message "Invalid certificate" and choose "Continue Anyway".

Process in pictures: http://slim.szm.sk/Opera/

I did similar in Firefox, and now, everything is OK !

But question is: Why I need show only one element from page, to get security message? Where is something like in IE: "Show content" ?!

share|improve this answer
1  
You will need to ask a new question - you can't ask questions within answers. This isn't a forum, it's a Q&A site, so Question at the top, only answers underneath! :) Feel free to ask a new question or edit your original question... By the way, your rep is now 11 so you can include pictures in your posts (recommended) – Dave Jul 31 '13 at 9:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .