Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Normally, Google Chrome Canary cannot be set to be the system's default browser - it shows the following message in its settings:

This is a secondary installation of Google Chrome, and cannot be made your default browser.

They have good reasons, but nevertheless I want to use it as my default. How can I set Google Chrome Canary as the default browser on Windows 8?

I found numerous solutions online about previous Windows versions, all revolving around editing the registry, and unfortunately none of them were able to solve this for me.

share|improve this question
    
Is there a developmental need to set it as default? Or you want canary to open when you click on hyperlinks? – meguroyama Sep 19 '13 at 7:47
    
@meguroyama the latter. – Oak Sep 19 '13 at 7:54
    
Try going into the system's default programs settings and configuring Chrome Canary to open HTTP links by default. – gparyani Sep 20 '13 at 19:50
up vote 6 down vote accepted

Replace YourUsernameHere with your user name. After that copy and paste the below into a text file and save it as canary.reg. then double click the file

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSHTML]
"URL Protocol"=""
@="Google Chrome Canary HTML Document"
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSHTML\DefaultIcon]
@="C:\\Users\\YourUsernameHere\\AppData\\Local\\Google\\Chrome SxS\\Application\\chrome.exe,4"
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSHTML\shell]
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSHTML\shell\open]
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSHTML\shell\open\command]
@="\"C:\\Users\\YourUsernameHere\\AppData\\Local\\Google\\Chrome SxS\\Application\\chrome.exe\" -- \"%1\""
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSURL]
@="Google Chrome Canary URL"
"FriendlyTypeName"="Google Chrome Canary URL"
"URL Protocol"=""
"EditFlags"=dword:00000002
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSURL\DefaultIcon]
@="C:\\Users\\YourUsernameHere\\AppData\\Local\\Google\\Chrome SxS\\Application\\chrome.exe,4"
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSURL\shell]
@="open"
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSURL\shell\open]
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeSxSURL\shell\open\command]
@="\"C:\\Users\\YourUsernameHere\\AppData\\Local\\Google\\Chrome SxS\\Application\\chrome.exe\" -- \"%1\""
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\FirefoxURL\shell\open\ddeexec]
@="\"%1\",,0,0,,,,"
"NoActivateHandler"=""
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\FirefoxURL\shell\open\ddeexec\Application]
@="Google Chrome Canary"
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\FirefoxURL\shell\open\ddeexec\Topic]
@="WWW_OpenURL"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\http\UserChoice]
"Progid"="ChromeSxSHTML"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\https\UserChoice]
"Progid"="ChromeSxSHTML"
[HKEY_CLASSES_ROOT\.htm]
@="ChromeSxSHTML"
"Content Type"="text/html"
"PerceivedType"="text"
[HKEY_CLASSES_ROOT\.html]
@="ChromeSxSHTML"
"Content Type"="text/html"
"PerceivedType"="text"
share|improve this answer
    
Thanks for sharing. How do i undo it? – xyz Jan 7 '15 at 6:55
    
Came across your post - unfortunately doesn't seem to work anymore with the latest version of chrome canary on windows 7 – Tom Jan 22 '15 at 8:45
    
This one works for me. techdows.com/2012/05/… – attomos Oct 27 '15 at 2:27

Control Panel > Default Programs > Set your default programs. Click on Google Chrome Canary and select "Set this program as default".

share|improve this answer
6  
It doesn't appear in the list of programs to choose from and there's no way to browse to add more programs. – Mike Hall Jan 31 '14 at 4:55
4  
I confirm this works on Windows 8.1. Not sure about other Windows versions. – Ngoc Pham Jun 12 '14 at 4:40
3  
It's not working on windows 7 – green Jun 12 '14 at 10:12
1  
This does work on Windows XP, however :/ – SuperScript Dec 23 '14 at 19:57
1  
Can confirm it works on Windows 7 64-bit – Jamie Hutber Jun 18 '15 at 9:07

Not answering the original question, but for people like me who might stumble upon this page when searching, the way to do it on OS X Yosemite (10.10) and up is in System Preferences -> General. Before it was in Safari's setting but now it's no longer the case.

share|improve this answer
    
You could create a new question for OS X Yosemite (10.10) and answer it yourself. Also, you could link that question to this one. But, adding an answer for another question is a wrong approach – Arashsoft 2 days ago

protected by Community Jul 18 '15 at 15:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.