Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Today I upgraded my FC18 system to FC19 by installing to a new disk.

Once booted I expected to be able to mount the previous boot disk logical volumes but the physical volumes are not visible to pvscan/pvdisplay. I do see both physical disks with fdisk.

How can I make my old disks' physical volumes visible to pvscan/pvdisplay?

Here's what I did: Yesterday I was booted off disk1 (LVM) and I could also mount disk2 (LVM with an old FC17).

Today I disconnected disk1 and installed FC19 onto disk2 creating a new filesystem/volumes.

I then reconnected both disks and booted to disk2.

Using fdisk -l I see my old disk /dev/sda and the partition containing my previous volumes: /dev/sda3.

But pvdisplay/pvscan only see the new disk volumes.

Thanks for any suggestions

share|improve this question
    
Might help if you post the actual output of pvscan. Also, how exactly did you do the install? –  Brian.D.Myers Jul 30 '13 at 23:30
    
Will do ... I'm not in front of the machine right now and I forgot to enable sshd yesterday ;-) –  Mike BRIGHT Jul 31 '13 at 7:32
    
I solved my problem last week very simply (but not satisfyingly as I wanted a command-line solution). By chance I'd setup a vncserver using xfce4 as window manager ... to my surprise I saw my 3T disk on the desktop ... just one click + password away. I'd have liked to have solved this with the appropriate LVM commands. I suppose that for some reason lvmetad hadn't recognized the disk (probably wasn't running before I ran xfce4). There you go ... that might help somebody. –  Mike BRIGHT Aug 6 '13 at 19:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.