Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got Java 1.7.0u25 installed on my system, but according to the About dialogue, Netbeans is running under 1.7.0u17. I'm having some minor but really annoying issues such as the delete key deleting 2 characters instead of one and I'm told that if Netbeans is running under the latest VM they should be resolved.

How do I force Netbeans to run under the latest VM installed on my system?

I tried googling for a solution but all I could find was articles about getting Netbeans to compile for particular JVMs.

I'm running Netbeans 7.3 fully updated on OSX Lion with Oracle's JVM.

share|improve this question
    
What version of Netbeans? Have you made sure you removed 7.0u17, on Windows, old versions are kept around for some odd reason even after newer update are instaled. –  Ramhound Jul 31 '13 at 11:14

2 Answers 2

One option is to use the --jdkhome <path> option when starting NetBeans. <path> is the root of the JDK installation.

Or locate netbeans.conf and change the following according to your JDK location:

netbeans_jdkhome="<path>"
share|improve this answer

Old thread, but maybe helpful (because I just ran across that due to the delete key bug):

Did you also update your JDK? Updating the Java VM that is used for Applets running in your Web browser and updating Netbeans itself (at least on my Mac) do not automatically update the JDK. Check for the newest SDK on Oracles Website. For me, it helped to download and install it - then Netbeans automatically used the new VM.

share|improve this answer
    
Will give that a try when I get home. –  GordonM Nov 18 '13 at 9:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.