Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu 9.04 on an Acer TravelMate 4200 laptop. I recently installed the video game World of Goo and it ran horridly choppy and unplayable. I suspect I need to install the proper video card drivers. Can anyone tell me:

  • How to determine in Ubuntu what video/graphics drivers I currently have.
  • Where to find the drivers and how to install them.

UPDATE: I have: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Thanks very much. I'm new to Ubuntu and just learning the ropes!

share|improve this question
    
Running sudo lspci -v Gives: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03) –  Sherri Oct 30 '09 at 22:36
add comment

4 Answers 4

I can help you with point one: run:

sudo lspci -v

and search for the section that reads like "VGA...controller". This will tell you the type.

If it's an nvidia card, use the binary driver from nvidia (worked pretty well last time i had used it)

If it's an ATI card, use AMD's driver (they only support the newest few cards, so you have to try). If it's not supported, try the radeon or radeonhd drivers.

If it's an intel card, I can't help you, since I never had one.

share|improve this answer
add comment

The Intel video driver in Ubuntu 9.04, is pretty bad, I recommend turning the Visual Effects off, (System->Preferences->Appearance (visual effect tab)), Update your Ubuntu the Intel driver is better now.

share|improve this answer
    
What does disabling the Visual Effects do? Will it improve the performance of programs using graphics effects, like games? –  Sherri Oct 30 '09 at 22:45
add comment

From the "system" menu,choose "Administration",then "Hardware Drivers"

it'll detect your video card,and also enables you to install its drivers

share|improve this answer
    
Hm... shocked I didn't notice that... sounds almost TOO easy... :) Wish I could vote this up, but I don't have rep yet. Thanks! –  Sherri Oct 29 '09 at 20:24
    
You're welcome :) ,if that worked for you,I'd appreciate it if you selected this as the correct answer for your question –  Mahmoud Hossam Oct 30 '09 at 2:31
    
It showed no proprietary drivers found. Hmm? –  Sherri Oct 30 '09 at 22:40
    
You can ask the people over at ubuntu forums,perhaps someone there has a solution for your problem –  Mahmoud Hossam Nov 1 '09 at 12:05
add comment
up vote 0 down vote accepted

Upgrading from Ubuntu 9.04 to 9.10 fixed the problem. Choppiness is gone. Thanks for all the other suggestions too!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.