Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to navigate to the start of a buffer with M-<, Emacs instead inserts a weird character ¯. How should I correct Emacs or Terminal.app to fix this?

$ specs emacs brew bash os
Specs:

specs 0.4
https://github.com/mcandre/specs#readme

emacs --version
GNU Emacs 24.3.1
Copyright (C) 2013 Free Software Foundation, Inc.
GNU Emacs comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of Emacs
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.

brew --version
0.9.4

bash --version
GNU bash, version 3.2.48(1)-release (x86_64-apple-darwin12)
Copyright (C) 2007 Free Software Foundation, Inc.

system_profiler SPSoftwareDataType | grep 'System Version'
      System Version: OS X 10.8.4 (12E55)

Update

Aha!

Terminal -> Preferences... -> Settings -> (profile) -> Keyboard -> Use option as meta key

share|improve this question
    
Note that it's OK to answer your own question :) –  IOXenus Jul 31 '13 at 14:04
1  
Not if your account is new, and SO's policies are retardedly restrictive. Don't have the karma yet. –  apennebaker Jul 31 '13 at 14:28

1 Answer 1

Eh, why not?

Terminal -> Preferences... -> Settings -> (profile) -> Keyboard -> Use option as meta key

Source: Homebrew CLI Emacs inserting ¯ when I press M-<

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.